Modify

Opened 5 years ago

Closed 4 years ago

#4642 closed defect (worksforme)

usermanager double entry in adminpanel

Reported by: tekknokrat Owned by: cbalan
Priority: normal Component: UserManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Theres a double entry of users in admin panel.

relevant config parts:

[components]
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.web_ui.loginmodule = enabled
acct_mgr.web_ui.registrationmodule = disabled
trac.web.auth.loginmodule = disabled
tracfullblog.admin.fullblogadminpanel = enabled
tracfullblog.core.fullblogcore = enabled
tracfullblog.db.fullblogsetup = enabled
tracfullblog.macros.bloglistmacro = enabled
tracfullblog.tags.fullblogtagsystem = enabled
tracfullblog.web_ui.fullblogmodule = enabled
tractags.api.tagsystem = enabled
tractags.macros.listtaggedmacro = enabled
tractags.macros.tagcloudmacro = enabled
tractags.model.tagmodelprovider = enabled
tractags.ticket.tickettagprovider = enabled
tractags.web_ui.tagrequesthandler = enabled
tractags.web_ui.tagtemplateprovider = enabled
tractags.wiki.tagwikisyntaxprovider = enabled
tractags.wiki.wikitaginterface = enabled
tractags.wiki.wikitagprovider = enabled
tractoc.macro.tocmacro = enabled
tracusermanager.account.admin_um.accountusermanagerpanel = enabled
tracusermanager.api.cachedsessionattributeprovider = enabled
tracusermanager.api.environmentfixknownusers = enabled
tracusermanager.api.sessionattributeprovider = enabled
tracusermanager.api.sessionuserstore = enabled
tracusermanager.api.usermanager = enabled
tracusermanager.permissions.admin_um.permissionusermanagerpanel = enabled
tracusermanager.profile.admin.userprofilefieldsadminpage = enabled
tracusermanager.profile.admin_um.userprofileusermanagerpanel = enabled
tracusermanager.profile.api.userprofilemanager = enabled
tracusermanager.profile.macros.defaultuserprofileslistcellcontributor = enabled
tracusermanager.profile.macros.teamrostermacro = enabled
tracusermanager.profile.macros.userprofileslistmacro = enabled
tracusermanager.profile.prefs.userprofilemodule = enabled
[um_profile-custom]
bio = wikitext
bio.cols = 70
bio.label = Skills
bio.order = 1
bio.rows = 10
gim = text
gim.cols = 20
gim.internal = 0
gim.label = email
gim.order = 2
gim.rows = 20
jim = text
jim.cols = 20
jim.label = Jabber
jim.order = 3
mim = text
mim.cols = 20
mim.label = MSN
mim.order = 6
mobile = text
mobile.cols = 30
mobile.internal = 0
mobile.label = mobile
mobile.order = 8
mobile.rows =
office = select
office.cols = 20
office.label = Office
office.options = |Office1|Office2
office.order = 3
phone = text
phone.cols = 30
phone.internal = 0
phone.label = Phone
phone.order = 7
phone.rows =
tags = multichecks
tags.label = Tags
tags.options = developer|engineer|manager
tags.order = 2
[account-manager]
password_file = /etc/subversion/fsvs-access.passwd
password_format = htpasswd
password_store = HtPasswdStore

Attachments (1)

trac-usermanager.png (3.0 KB) - added by tekknokrat 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by tekknokrat

comment:1 Changed 5 years ago by anonymous

This is caused by the AccountManagerPlugin trying to manager users as well as the UserManagerPlugin managing users.

Add acct_mgr.admin.accountmanageradminpage = disabled to your [components] to remove the dual entry.

comment:2 Changed 4 years ago by lkraav

if comment:1 is the solution (which I believe it is), could someone relevant perhaps close this ticket?

comment:3 Changed 4 years ago by tekknokrat

  • Resolution set to worksforme
  • Status changed from new to closed

solution from comment:1 works, thanks.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from cbalan. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.