Modify

Opened 8 years ago

Closed 8 years ago

#479 closed defect (duplicate)

GeneralLinkSyntaxPlugin interferes with InterTrac

Reported by: uwe.belde@… Owned by: gotoh
Priority: normal Component: GeneralLinkSyntaxPlugin
Severity: normal Keywords: intertrac
Cc: Trac Release: 0.10

Description

The following configuration leads to ambiguous Wiki-Links and to an internal error

[link]
pizza_url = https://my.server.com/projects/pizza
pizza_disp = pizza:%s
expose = pizza
names = pizza

[intertrac]
pizza.title = Pizza
pizza.url = https://my.server.com/projects/pizza

So pizza:ticket:1 is a valid ticket, but not a valid general link.
GeneralLinkSyntaxPlugin is only for 0.9 at the moment, but this could to confusion if 0.10 stable is out.

Python Traceback

Traceback (most recent call last):
  File "D:\Python23\Lib\site-packages\trac\web\main.py", line 314, in dispatch_request
    dispatcher.dispatch(req)
  File "D:\Python23\Lib\site-packages\trac\web\main.py", line 199, in dispatch
    resp = chosen_handler.process_request(req)
  File "D:\Python23\Lib\site-packages\trac\versioncontrol\web_ui\log.py", line 162, in process_request
    changes = get_changes(self.env, repos, revs, verbose, req, format)
  File "D:\Python23\Lib\site-packages\trac\versioncontrol\web_ui\util.py", line 45, in get_changes
    shortlog = wiki_to_oneliner(message, env, db, shorten=True)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 1009, in wiki_to_oneliner
    OneLinerFormatter(env, absurls, db).format(wikitext, out, shorten)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 920, in format
    result = re.sub(self.wiki.rules, self.replace, result)
  File "D:\Python23\lib\sre.py", line 143, in sub
    return _compile(pattern, 0).sub(repl, string, count)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 774, in replace
    replacement = self.handle_match(fullmatch)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 770, in handle_match
    return internal_handler(match, fullmatch)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 344, in _shref_formatter
    return self._make_link(ns, target, match, match)
  File "D:\Python23\Lib\site-packages\trac\wiki\formatter.py", line 371, in _make_link
    escape(label, False))
  File "build\bdist.win32\egg\GeneralLinkSyntax\api.py", line 177, in _format_exposed_link
  File "build\bdist.win32\egg\GeneralLinkSyntax\api.py", line 193, in _format_link
ValueError: unpack list of wrong size

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by cboos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #163. See also #42.

AFAIK, there's nothing the GeneralLinkSyntaxPlugin can do
that can't be done with InterTrac or InterWiki links, in
trac:milestone:0.10.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from gotoh. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.