Modify

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#4808 closed defect (fixed)

Function getStatus not found

Reported by: willner@… Owned by: etienne
Priority: normal Component: TracBuildbotIntegration
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Dear Etienne,

I've checked out and installed the latest version of your TracBuildbot plugin on Trac 0.11.1 with Buildbot 0.7.10. Unfortunately I get an internal error when opening the "/buildbot" URL:

2009-03-19 16:39:32,299 Trac[__init__] ERROR: <Fault 8001: 'function getStatus not found'>
Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 423, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.1-py2.5.egg/trac/web/main.py", line 197, in dispatch
    resp = chosen_handler.process_request(req)
  File "build/bdist.linux-i686/egg/tracbb/tracbb.py", line 130, in process_request
    data['bb_builders'] = self.get_builders(req)
  File "build/bdist.linux-i686/egg/tracbb/tracbb.py", line 78, in get_builders
    'status' : server.getStatus(builder),
  File "xmlrpclib.py", line 1147, in __call__    return self.__send(self.__name, args)  File "xmlrpclib.py", line 1437, in __request    verbose=self.__verbose  File "xmlrpclib.py", line 1201, in request
    return self._parse_response(h.getfile(), sock)
  File "xmlrpclib.py", line 1340, in _parse_response
    return u.close()
  File "xmlrpclib.py", line 787, in close
    raise Fault(**self._stack[0])
Fault: <Fault 8001: 'function getStatus not found'>

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by etienne

The problem is that I rely on xmlrpc functions that were provided with buildbot and seem to have been removed. I'll have to see if it wouldn't be better to using twisted functions as used by the various clients in buildbot/clients

comment:2 Changed 6 years ago by etienne

  • Status changed from new to assigned

comment:3 Changed 6 years ago by etienne

  • Resolution set to fixed
  • Status changed from assigned to closed

I've checked in a few changes, the xmlrpc functions have changed a bit in last versions of buildbot, the status is now returned with the other informations.

comment:4 Changed 6 years ago by anonymous

Confirmed. Thanks a lot.

Add Comment

Modify Ticket

Action
as closed The owner will remain etienne.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.