Modify

Opened 6 years ago

Closed 5 years ago

#4809 closed defect (worksforme)

EOF when reading a line

Reported by: rodrigo.benenson@… Owned by: roadrunner
Priority: normal Component: HudsonTracPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

After normal setup with latest stable Trac (0.11.3) and Hudson (ver. 1.292) I get

Hudson Builds event provider (HudsonTracPlugin) failed: EOFError: EOF when reading a line <<<

when looking at the timeline

the RSS feed provided in trac.ini feed_url = http://localhost:8080/hudson/rssAll seem perfectly normal to me

Attachments (0)

Change History (4)

comment:1 Changed 6 years ago by roadrunner

Please provide more details. At the very least a full stack trace (try turning on debug level logging). If you can also provide a sample of your rss feed, that would be great.

comment:2 Changed 6 years ago by anonymous

So trac.log gives:

2009-03-20 15:05:19,487 Trac[main] DEBUG: Dispatching <Request "GET u'/timeline'"> 2009-03-20 15:05:19,488 Trac[session] DEBUG: Retrieving session for ID 'rodrigo.benenson' 2009-03-20 15:05:21,252 Trac[chrome] DEBUG: Prepare chrome data for request 2009-03-20 15:05:21,319 Trac[web_ui] ERROR: Timeline event provider failed: Traceback (most recent call last):

File "/usr/lib/python2.5/site-packages/Trac-0.11.3-py2.5.egg/trac/timeline/web_ui.py", line 160, in process_request

filters):

File "build/bdist.linux-i686/egg/HudsonTrac/HudsonTracPlugin.py", line 95, in get_timeline_events

line = urllib.urlopen(url).readline()

File "/usr/lib/python2.5/urllib.py", line 82, in urlopen

return opener.open(url)

File "/usr/lib/python2.5/urllib.py", line 190, in open

return getattr(self, name)(url)

File "/usr/lib/python2.5/urllib.py", line 338, in open_http

return self.http_error(url, fp, errcode, errmsg, headers)

File "/usr/lib/python2.5/urllib.py", line 351, in http_error

result = method(url, fp, errcode, errmsg, headers)

File "/usr/lib/python2.5/urllib.py", line 680, in http_error_401

return getattr(self,name)(url, realm)

File "/usr/lib/python2.5/urllib.py", line 744, in retry_http_basic_auth

user, passwd = self.get_user_passwd(host, realm, i)

File "/usr/lib/python2.5/urllib.py", line 773, in get_user_passwd

user, passwd = self.prompt_user_passwd(host, realm)

File "/usr/lib/python2.5/urllib.py", line 782, in prompt_user_passwd

host))

EOFError: EOF when reading a line 2009-03-20 15:05:21,321 Trac[main] WARNING: HTTPInternalError: 500 Trac Error (<p class="message">Hudson Builds event provider (<tt>HudsonTracPlugin</tt>) f\ ailed:<br/>EOFError: EOF when reading a line</p><p>You may want to see the other kind of events from the <a href="/Weboloco/Trac/timeline?ticket=on&amp;chan\ geset=on&amp;milestone=on&amp;wiki=on">Timeline</a></p>) 2009-03-20 15:05:21,455 Trac[main] DEBUG: 14524 unreachable objects found <<<<<

and the feed at feed_url = htCHANGEDTOAVOIDTRACBLOCKtp://localhost:8080/hudson/rssAll?flavor=rss20 looks like the attached file rss20.txt and feed_url = htCHANGEDTOAVOIDTRACBLOCKtp://localhost:8080/hudson/rssAll?flavor=atom looks like the file atom.txt

(files available at htCHANGEDTOAVOIDTRACBLOCKtp://rodrigo.benenson.googlepages.com/atom.txt and htCHANGEDTOAVOIDTRACBLOCKtp://rodrigo.benenson.googlepages.com/rss20.txt )

I tried both and got the same error. I also tried feed_url = htCHANGEDTOAVOIDTRACBLOCKtp://login:password@www.MyProject.com/MyProject/Hudson/rssAll?flavor=rss20 same error and feed_url = /MyProject/Hudson/rssAll?flavor=rss20 gives "nothing" (no extra elements, no errors in log).

I hope this helps.

Regards, rodrigob.

comment:3 Changed 5 years ago by roadrunner

This may be related to #5355, since this is also occurring while trying to retrieve the build infos. As of r6007 you can now disable this behaviour via a config option - that should help you work around what seems to be bug in Hudson.

comment:4 Changed 5 years ago by roadrunner

  • Resolution set to worksforme
  • Status changed from new to closed

As of version 0.3 (r6683, actually) the plugin does not use the rss feed anymore, but instead uses Hudson's api. Therefore closing this ticket, but feel free to re-open if you can reproduce this with the current version of the plugin.

Add Comment

Modify Ticket

Action
as closed The owner will remain roadrunner.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.