Modify

Opened 5 years ago

Closed 5 years ago

#4908 closed defect (fixed)

Infinite recursion when using r5468 to get all search filters

Reported by: JasonWinnebeck Owned by: anonymous
Priority: normal Component: SearchAllPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

get_search_filters causes "RuntimeError: maximum recursion depth exceeded" whenever trying to load the search page (not performing a query).

The stack trace loops forever on the line 81 (shown below).

                available_filters += source.get_search_filters(req)

Reverting back to r5455, the plugin works for me.

Attachments (0)

Change History (4)

comment:1 Changed 5 years ago by airadier

  • Owner changed from airadier to anonymous
  • Status changed from new to assigned

I think I guess what the problem is... I have Search All enabled in only one of my projects. I guess you have search all enabled in more than one project... is that right?

comment:2 Changed 5 years ago by JasonWinnebeck

Yes I have 7 Trac projects, and each of them have this plugin installed. I thought that was the only way to set this up? I guess the other way is to have a master project? I haven't figured out any of those plugins, mostly because I haven't gotten a good feeling that they are stable/complete yet.

comment:3 Changed 5 years ago by airadier

It's a bug in my plugin, anyways, but I didn't notice it as I have a kind of master or index project with SearchAll, and no Search All in the others.

I'll fix it as soon as I get back to work on monday, it should be an easy fix.

Thanks for the reprt.

comment:4 Changed 5 years ago by airadier

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [5515]) Fixes infinite recursion if searchall plugin enabled in more than one project. Closes #4908

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from anonymous. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.