Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#4916 closed defect (invalid)

Attachments fail

Reported by: izzy Owned by: otaku42
Priority: high Component: TracHacks
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

As you can see in #4915, uploaded patches fail to be stored. Maybe a full disk or the like? The size is shown correctly, the content is missing - and hitting on "original format" just gives a "file not found".

Attachments (3)

attachment-test.txt (46 bytes) - added by otaku42 5 years ago.
Attachment test #1
formats.py.titlefile+multiformat+lang.patch (3.3 KB) - added by otaku42 5 years ago.
Cumulative patch to evaluate the language from the patched form, incl. patch from #4747 (PS+HTML output) and #4696 (titlefile keyword)
formats.py.titlefile+multiformat+lang.2.patch (3.3 KB) - added by otaku42 5 years ago.
Same patch again, this time with a different description

Download all attachments as: .zip

Change History (9)

Changed 5 years ago by otaku42

Attachment test #1

comment:1 Changed 5 years ago by otaku42

  • Status changed from new to assigned

As you can see, attachments generally work. I've just checked whether the attachments you made to #4915 have been stored on the server: they were. Probably an issue related to the (file) name of the attachments, need to investigate that further. Meanwhile, please retry attaching with a different file name.

comment:2 follow-up: Changed 5 years ago by izzy

Thank you - I already tried and failed again (see the last try, changed the file extension to .diff instead of .patch). Since the code is available inline (I just pasted it), I guess I better wait until you found out what's going on there - and try again then. If you don't mind.

Anyhow, thank you for the fast reaction and response - and good luck with the investigations!

By the way, some notes to hopefully help you - this is what I did:

  1. attachment 1 added (fine)
  2. attachment 2 added (fine)
  3. noticed I had an error in the 2nd attachment - tried to replace (using the checkbox to overwrite the existing file). And here the trouble began: It said the right size, but showed no content
  4. tried again, this time without the checkbox marked - same problem
  5. tried again, using different file name - still the same problem.

At this place I decided to paste the content (so the patch is available), and open a "system ticket" for the problem.

comment:3 in reply to: ↑ 2 Changed 5 years ago by otaku42

Replying to izzy:

Thank you - I already tried and failed again (see the last try, changed the file extension to .diff instead of .patch).

Still need to investigate, but I think the issue is caused by the use of "+"-signs as part of the file name. Please test that.

comment:4 Changed 5 years ago by izzy

I don't think so - I used similar filenames before (see the tickets mentioned in the comment) without problems. And the first time the attachment worked as well (see comment:2) - problems started when I tried to replace it.

Changed 5 years ago by otaku42

Cumulative patch to evaluate the language from the patched form, incl. patch from #4747 (PS+HTML output) and #4696 (titlefile keyword)

Changed 5 years ago by otaku42

Same patch again, this time with a different description

comment:5 Changed 5 years ago by otaku42

  • Resolution set to invalid
  • Status changed from assigned to closed

Ok, found the issue:

$ patch -p0 < formats.py.titlefile%2Bmultiformat%2Blang.patch
patching file formats.py
patch: **** malformed patch at line 10: @@ -37,8 +31,10 @@
$

In other words: attachments work fine, but Trac fails to render the content since the diff/patch file is malformed.

Closing this ticket as invalid :-)

comment:6 Changed 5 years ago by izzy

Oops (testing) - yepp, right. Re-created the diff, attaches fine now. Confirmed: Error sat in front of keyboard. Sorry for the trouble - shame on me (and a little bit on the missing error message which had shown it to me earlier ;)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from otaku42. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.