Modify

Opened 6 years ago

Closed 19 months ago

#4919 closed enhancement (fixed)

Suppress CC change email

Reported by: anonymous Owned by: rjollos
Priority: normal Component: DefaultCcPlugin
Severity: normal Keywords:
Cc: oliver.staron@… Trac Release: 1.0

Description

Is there a way to suppress the notification email for when it does the CC change?

Attachments (0)

Change History (15)

comment:1 Changed 2 years ago by rjollos

Maybe we could modify the DB directly rather than using ticket.save_changes?

comment:2 Changed 2 years ago by rjollos

  • Cc o.staron@… added; anonymous removed

Fixed with help from Pete Suter on the Trac Dev mail list.

comment:3 Changed 2 years ago by rjollos

(In [11747]) Refs #4919: Modify CC list at the time of ticket creation, rather than after the ticket is created. This avoids an immediate comment change and email notification. Strip leading and trailing whitespace from the ticket. Thanks to Pete Suter with hints on the implementation.

comment:4 Changed 2 years ago by rjollos

  • Owner changed from jeangui to rjollos
  • Status changed from new to assigned

comment:5 Changed 2 years ago by rjollos

  • Cc oliver.staron@… added; o.staron@… removed

comment:6 follow-ups: Changed 2 years ago by anonymous

Hi, my first testresult:

my previously needed workaround in defaultcc\main.py is not needed anymore, great!

BUT: When I open a new ticket no owner is assigned to the ticket !!!!!!!!

Another thing I wanted to mention: defaultccplugin is still not shown at title page of trac-hacks wiki. I orignially found it via google. :-)

comment:7 Changed 2 years ago by oliver.staron@…

  • Trac Release changed from 0.11 to 1.0

sorry, forgot to tell who I am :-)

comment:8 in reply to: ↑ 6 ; follow-up: Changed 2 years ago by rjollos

Replying to anonymous:

Another thing I wanted to mention: defaultccplugin is still not shown at title page of trac-hacks wiki. I orignially found it via google. :-)

That is strange, it shows for me. Is it possible that one of the 0.11, 0.12 or 1.0 filters is not selected?: WikiStart#Hacks

comment:9 in reply to: ↑ 6 ; follow-up: Changed 2 years ago by rjollos

Replying to anonymous:

Hi, my first testresult:

my previously needed workaround in defaultcc\main.py is not needed anymore, great!

BUT: When I open a new ticket no owner is assigned to the ticket !!!!!!!!

What was your workaround?

I'm not able to reproduce this issue. Did you make sure that the Component has an owner? Are there any other details you can provide, such as which revision of the plugin the problem first appeared? I'm having trouble imagining how the issue you describe could be caused by this plugin, so I'm not where to start investigating since I can't reproduce the issue at the moment.

I did notice while trying to reproduce #5920, that the ticket owner is not assigned from the Component owner if tickets are created through the Eclipse plugin, but this seems to be a bug with either the Trac Mylyn-Eclipse or XmlRpcPlugin.

comment:10 in reply to: ↑ 9 Changed 2 years ago by oliver.staron@…

My workaround in defaultcc/main.py (up to defaultccplugin-r11735.zip) Line 43 was:

Instead of:

        ticket.save_changes('DefaultCC Plugin', '')

I used:

        ticket.save_changes('', '')

Otherwise the tool wanted always to send an email to "DefaultCC Plugin".

Now with defaultccplugin-r11753.zip this is not necessary anymore, but as I said: Even an owner for the component is configured, the owner was not be set in the ticket. The configured CC for the component was added properly as CC.

comment:11 in reply to: ↑ 8 Changed 2 years ago by oliver.staron@…

Replying to rjollos:

Replying to anonymous:

Another thing I wanted to mention: defaultccplugin is still not shown at title page of trac-hacks wiki. I orignially found it via google. :-)

That is strange, it shows for me. Is it possible that one of the 0.11, 0.12 or 1.0 filters is not selected?: WikiStart#Hacks

Fine, now it there, thanks. Mayby I was too blind before :-)

comment:12 Changed 2 years ago by rjollos

Could we try a couple of debug steps?:

  • Turn on t:TracLogging and look for any errors on ticket creation.
  • Disable the DefaultCcPlugin and check that the owner is correctly assigned when this plugin is not installed.

I've tested on Trac 1.0dev-r11123 so far.

comment:13 Changed 2 years ago by oliver.staron@…

ok, sorry, I found out that it seems to be a general problem with my Trac Rel1.0 Server, that the Owner is not assigned. I has nothing to do with the DefaultCCplugin.

If possible, please just remove all my comments regarding this in this ticket.

comment:14 Changed 2 years ago by rjollos

Sure, no problem. Glad we have that figured out :)

comment:15 Changed 19 months ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.