Modify

Opened 5 years ago

Closed 5 years ago

#5204 closed defect (duplicate)

Install process doesn't create tables

Reported by: my.home.my.castle@… Owned by: coling
Priority: normal Component: ClientsPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

After installation using python setup.py install command trac-admin /env upgrade upgrades database, again and again, but doesn't create tables from api.py.

Uploading egg using Trac Admin form behaves the same.

Manually created tables are useless, because adding a client tries to insert empty string into 'default_rate INTEGER', what is rejected by PostgreSQL. Viewing client causes AssertionError.

Trac 0.11.4, ClientsPlugin downloaded today from SVN.

Attachments (0)

Change History (1)

comment:1 Changed 5 years ago by coling

  • Resolution set to duplicate
  • Status changed from new to closed

Seems like a dupe of #4805. I'd appreciate testers there. I may have fixed it but I suspect there may still be a problem with PG.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coling. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.