Modify

Opened 6 years ago

Closed 5 years ago

#5274 closed defect (wontfix)

Support for AccountManager login module

Reported by: turkanis Owned by: ivangsa
Priority: normal Component: WikiEditorForEclipsePlugin
Severity: minor Keywords:
Cc: Trac Release: 0.11

Description (last modified by ivangsa)

I recently reconfigured my Trac installations to use the AccountManager login module instead of HTTP authentication, and now I get the error "Error connecting to server: Permission Denied" when I try to connect to Trac through the TracWikiEditor.

Does TracWikiEditor support this type of authentication?

Attachments (0)

Change History (3)

comment:1 Changed 6 years ago by ivangsa

  • Status changed from new to assigned

Hi turkanis,

the plugin currently only supports BASIC authentication.

If you are using AccountManagerPlugin#LoginModule to use form based login you can still use HttpAuthPlugin to re-enable Http BASIC authentication for /login/xmlrpc path to make it work with XmlRpcPlugin.

see XmlRpcPlugin#ProblemswhenAccountManagerPluginisenabled for details

Regards
Ivan

comment:2 Changed 6 years ago by ivangsa

  • Severity changed from normal to minor

comment:3 Changed 5 years ago by ivangsa

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from assigned to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain ivangsa.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.