Modify

Opened 5 years ago

Closed 4 years ago

#5294 closed defect (invalid)

Cannot connect to local Hudson running under jboss

Reported by: simonw@… Owned by: roadrunner
Priority: normal Component: HudsonTracPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

When I configure this plugin with a url that points to Hudson running under JBoass AS 4.2 I get a connection refused message. I am using the url http://localhost:8080/hudson/rssAll

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by roadrunner

Make sure you have the correct port configured. Try testing the the url on the
command line. Basically this looks like some local configuration issue.

comment:2 Changed 5 years ago by anonymous

I have rechecked the URL and there was a slight error which I introduced to try and fix what may be the actual problem. That being that if I do not get the error message listed initially, I dont actually get any text from Hudson appear in the time-line. I can access the URL from the command line and a wget actually downloads the rss feed. I am using trac 0.11.1

comment:3 Changed 5 years ago by roadrunner

Sorry, I'm slightly confused: are you saying that the timeline appears
fine except that there are no entries at all for the hudson builds?
Or are there entries but they're empty? Or what?

There's no way for me to directly debug this, as I don't have a jboss
setup. Can you possibly try adding some print statements to the loop
starting at line 85 and see if you can narrow down the issue?

comment:4 Changed 5 years ago by roadrunner

Can you also check if you can access the build-infos? Take the url for
a given build (e.g. /hudson/job/BuildFoo/142) and append /api/json
to it (i.e. /hudson/job/BuildFoo/142/api/json) and see if you can
retrieve that. This is the url used to retrieve the build
descriptions.

comment:5 Changed 4 years ago by roadrunner

  • Resolution set to invalid
  • Status changed from new to closed

No more feedback from submitter, and cannot reproduce. Also, the
plugin is now using the api rather than the rss feed, so I suspect
this issue is either fixed or it's some jboss config problem.

Hence closing this. Feel free to reopen if you are willing to
provide more info.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from roadrunner. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.