Modify

Opened 8 years ago

Closed 8 years ago

#540 closed defect (duplicate)

Permission denied with TracAccountManager-0.1.2

Reported by: anonymous Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.9

Description

Oops...
Trac detected an internal error:

[Errno 13] Permission denied


Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/modpython_frontend.py", line 206, in handler
    dispatch_request(mpr.path_info, mpr, env)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 139, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 107, in dispatch
    resp = chosen_handler.process_request(req)
  File "/var/trac/projects/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 51, in process_request
  File "/var/trac/projects/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/web_ui.py", line 67, in _do_change_password
  File "/var/trac/projects/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/api.py", line 88, in set_password
  File "/var/trac/projects/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/htfile.py", line 50, in set_password
  File "/var/trac/projects/test/plugins/TracAccountManager-0.1.2.egg/acct_mgr/htfile.py", line 77, in _update_file
  File "/usr/lib/python2.4/fileinput.py", line 231, in next
    line = self.readline()
  File "/usr/lib/python2.4/fileinput.py", line 300, in readline
    os.rename(self._filename, self._backupfilename)
OSError: [Errno 13] Permission denied

I don't realy know on wich file is Permission denied

User apache is owner and have write permissions to:

  • trac project directory
  • python egg cache
  • htpasswd file witch is used by TracAccountManager
  • TracAccountManager-0.1.2.egg in plugin directory of trac project

What should I do ... ?

Attachments (0)

Change History (1)

comment:1 Changed 8 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of #537.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.