Modify

Opened 5 years ago

Closed 4 years ago

#5405 closed defect (duplicate)

Error when trying to upgrade database ("object has no attribute 'rollback'", PostgreSQL)

Reported by: anonymous Owned by: rjollos
Priority: normal Component: VotePlugin
Severity: blocker Keywords: psycopg2 rollback upgrade trac-admin
Cc: Trac Release: 0.11

Description

When trying to upgrade database after enabling voteplugin:

sp2043a tracproject # trac-admin . upgrade
/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/util/__init__.py:21: DeprecationWarning: the md5 module is deprecated; use hashlib instead
  import md5
/usr/lib/python2.6/site-packages/MySQLdb/__init__.py:34: DeprecationWarning: the sets module is deprecated
  from sets import ImmutableSet
Traceback (most recent call last):
  File "/usr/bin/trac-admin", line 8, in <module>
    load_entry_point('Trac==0.11', 'console_scripts', 'trac-admin')()
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/admin/console.py", line 1249, in run
    return admin.onecmd(command)
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/admin/console.py", line 104, in onecmd
    rv = cmd.Cmd.onecmd(self, line) or 0
  File "/usr/lib/python2.6/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/admin/console.py", line 1103, in do_upgrade
    if not self.__env.needs_upgrade():
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/env.py", line 414, in needs_upgrade
    if participant.environment_needs_upgrade(db):
  File "build/bdist.linux-i686/egg/tracvote/__init__.py", line 142, in environment_needs_upgrade
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/db/util.py", line 36, in __getattr__
    return getattr(self.cursor, name)
  File "/usr/lib/python2.6/site-packages/Trac-0.11-py2.6.egg/trac/db/util.py", line 36, in __getattr__
    return getattr(self.cursor, name)
AttributeError: 'psycopg2._psycopg.cursor' object has no attribute 'rollback'

Trac 0.11, VotePlugin 0.11, Psycopg2 2.0.11

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by anonymous

  • Owner changed from athomas to anonymous
  • Status changed from new to assigned

comment:2 Changed 5 years ago by anonymous

  • Owner changed from anonymous to athomas
  • Status changed from assigned to new

comment:3 Changed 5 years ago by tod@…

yes, I got same problem.

comment:6 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos

Reassigning ticket to new maintainer.

comment:7 Changed 4 years ago by rjollos

Duplicate of #5245. Should be fixed with latest 0.11 version.

comment:8 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.