Modify

Opened 8 years ago

Closed 8 years ago

#543 closed defect (duplicate)

passwd files don't reload if trac runs as a standalone server

Reported by: sgrayban Owned by: mgood
Priority: highest Component: AccountManagerPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.9

Description

I have the plugin setup to use htpasswd and the issue happens after a person register's the file isn't reloaded by trac to see the new user.

Is this something I'm doing wrong or is there something in the doc's I am missing?

I am running trac as a standalone server also. I think this is the real problem.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by sgrayban

  • Priority changed from high to highest
  • Summary changed from htpasswd file doesn't reload to passwd files don't reload if trac runs as a standalone server

This is a serious issue for the standalone trac server. The normal functions a real http server doesn't have this problem.

I have to manually reload/restart trac for it to see the new users. I guess trac when run as a standalone must store the files in memory and doesn't see the changes made.

comment:2 Changed 8 years ago by mgood

  • Resolution set to duplicate
  • Status changed from new to closed

This is a duplicate of trac:#2714.

The issue is in tracd itself, it has nothing to do with the AccountManagerPlugin. However, with the Trac trunk you can use tracd with the AccountManagerPlugin's login form, which will reread new users from the password file.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.