Modify

Opened 5 years ago

Closed 4 years ago

#5451 closed defect (duplicate)

VotePlugin failing on trac-admin upgrade

Reported by: p.pover@… Owned by: rjollos
Priority: high Component: VotePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Fails to run the trac-admin upgrade.

Traceback:

Traceback (most recent call last):
  File "/usr/bin/trac-admin", line 7, in ?
    sys.exit(
  File "/usr/lib64/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/admin/console.py", line 1249, in run
    return admin.onecmd(command)
  File "/usr/lib64/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/admin/console.py", line 104, in onecmd
    rv = cmd.Cmd.onecmd(self, line) or 0
  File "/usr/lib64/python2.4/cmd.py", line 219, in onecmd
    return func(arg)
  File "/usr/lib64/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/admin/console.py", line 1103, in do_upgrade
    if not self.__env.needs_upgrade():
  File "/usr/lib64/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/env.py", line 414, in needs_upgrade
    if participant.environment_needs_upgrade(db):
  File "build/bdist.linux-x86_64/egg/tracvote/__init__.py", line 142, in environment_needs_upgrade
  File "/usr/lib64/python2.4/site-packages/Trac-0.11-py2.4.egg/trac/db/util.py", line 36, in __getattr__
    return getattr(self.cursor, name)
  File "/usr/lib64/python2.4/site-packages/sqlite/main.py", line 421, in __getattr__
    raise AttributeError, key
AttributeError: rollback

I noticed others had similar problems. Any way to fix this? I'm a bit of a Python novice, but a quick explanation on how to fix should get me going. Thanks.

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by rjollos

  • Owner changed from athomas to rjollos

Reassigning ticket to new maintainer.

comment:2 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5245. Should be fixed with latest 0.11 version.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.