Modify

Opened 5 years ago

Closed 3 years ago

#5452 closed defect (fixed)

Calender no longer opens after update to new version

Reported by: hju@… Owned by: doki_pen
Priority: normal Component: DateFieldPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

After updating to the "new 1.0.1" version (06/29/09) of the plugin due to fix of #1726, the calender no longer opens.

The Plugin is replaced (the new calender-icon is displayed), but no calender opens if you click the icon or enter the field.
I get the following error/warning:

2009-06-30 12:18:16,155 Trac[__init__] WARNING: File images/ui-icons_ffffff_256x240.png not found in any of ['/var/www/.python-eggs/TracDateField-1.0.1-py2.4.egg-tmp/datefield/htdocs']
2009-06-30 12:18:16,178 Trac[__init__] WARNING: File images/ui-bg_glass_100_f6f6f6_1x400.png not found in any of ['/var/www/.python-eggs/TracDateField-1.0.1-py2.4.egg-tmp/datefield/htdocs']
2009-06-30 12:18:16,229 Trac[__init__] WARNING: File images/ui-bg_gloss-wave_35_f6a828_500x100.png not found in any of ['/var/www/.python-eggs/TracDateField-1.0.1-py2.4.egg-tmp/datefield/htdocs']
2009-06-30 12:18:16,235 Trac[__init__] WARNING: File images/ui-bg_highlight-soft_75_ffe45c_1x100.png not found in any of ['/var/www/.python-eggs/TracDateField-1.0.1-py2.4.egg-tmp/datefield/htdocs']
2009-06-30 12:18:16,789 Trac[__init__] WARNING: 404 Not Found (File images/ui-icons_ffffff_256x240.png not found)
2009-06-30 12:18:16,809 Trac[__init__] WARNING: 404 Not Found (File images/ui-bg_glass_100_f6f6f6_1x400.png not found)
2009-06-30 12:18:16,860 Trac[__init__] WARNING: 404 Not Found (File images/ui-bg_gloss-wave_35_f6a828_500x100.png not found)
2009-06-30 12:18:16,880 Trac[__init__] WARNING: 404 Not Found (File images/ui-bg_highlight-soft_75_ffe45c_1x100.png not found)

The source of this reguest is in jquery-ui.css

I could not find the requested .pngs - is there something missing in the package?

Attachments (0)

Change History (34)

comment:1 Changed 5 years ago by hju@…

  • Owner changed from coderanger to doki_pen

sorry, wrong owner

comment:2 Changed 5 years ago by doki_pen

Any more details? What browser? What other plugins do you have
installed? Do you have firebug or something to debug with?

comment:3 Changed 5 years ago by anonymous

BTW. I've added the images, but that shouldn't have stopped it from opening and it was opening on my machine before adding the images.

comment:4 Changed 5 years ago by hju@…

Well, I use Firefox 3.0.11
There are lots of plugins runing (TracWysiwigPlugin, TracAccountManagerPlugin, AdvancedTicketWorflowPlugin, FlexibleReporterNotification, TracTocMakro, Email2tracPlugin) but I don't expect any problems there.
Firebug is installed, but honestly I never used it.

In between I made some more strange observations:
After reeinstalling the "old egg-file" tuesday I tried again to update today, deleting the "old eggs" and restarting the apache. I got the new calender-icon and the warnings disapeared - but the opening calender had again the error described in #1726...
Trying out several combinations of first_day = by accident I used first_day = 8 resulting in the return of the warnings and no more calender opening.
Restarting Firefox doesn't help.

Sorry, but I've no idea whats wrong. I will create a new egg with the missing images... perhaps it will help.

comment:5 Changed 5 years ago by doki_pen

if you ping me on irc (#trac on freenode) I can help you out more. doki_pen is my nick. I don't think first_day 8 would work, it's the first day of the week in the calendar, and AFAIK, there are only 7 days in a week. As far as firebug goes, I would just look for any errors. Also, if it's not to much trouble, try running the plugin on a new project that doesn't have any other plugins enabled. (or just disable everything on the one you are using.) See if the problem still remains. Also, paste the relevant config sections here. I am not able to reproduce this locally.

comment:6 Changed 5 years ago by doki_pen

also, I'm assuming your are checking the code out of svn and installing, right?

comment:7 Changed 5 years ago by hju@…

No, I use the zipped source and create an egg on the server.

I know that first_day = 8 was wrong. I was surprised that this reproduces the errors/warnings and they stay permanentely regardeless other (correct) entrys afterwards.

I'll try to ping you afternoon:
Here are the relevant parts of the config section:

[components]
...
datefield.* = enabled

[datefield]
first_day = 1
format = dmy
separator = .

[ticket-custom]
due_date = text
due_date.date = true
due_date.date_empty = true
due_date.label = Initial due date
due_date.order = 1
new_due_date = text
new_due_date.date = true
new_due_date.date_empty = true
new_due_date.label = Current due date
new_due_date.order = 2

comment:8 Changed 5 years ago by hju@…

Disabeling the plugins has no effekt.

comment:9 Changed 5 years ago by doki_pen

You created the zip through the trac svn browser?

comment:10 Changed 5 years ago by hju@…

I don't know if it is created. I download the zipped code from here and unzip it.
Then I create the .egg with

python setup.py bdist_egg

If it is a new plugin I use easy_install to put it in place and activate the new component in trac.ini
Or (if there was a previos version) I copy the .egg in the /site-packages folder and remove the previous .egg.tmp file in the .python-eggs folder.
Afterwards I restart the webserver to clear the cache.

comment:11 follow-up: Changed 5 years ago by doki_pen

do you need to chmod all the files that are extracted from the zip? They all had 0 permission for me..

comment:12 Changed 5 years ago by anonymous

I did the same thing (but also chmod on all files to 500 before bdist_egg. And it works fine for me. Perhaps it's a web config issue? Can you try with tracd? Also, try with latest trac.

comment:13 in reply to: ↑ 11 Changed 5 years ago by hju@…

Replying to doki_pen:

do you need to chmod all the files that are extracted from the zip? They all had 0 permission for me..

No. I unzip them on my client and move them to the server via winscp. No problems with permissions...

comment:14 follow-up: Changed 5 years ago by doki_pen

Try with tracd and latest Trac.

comment:15 in reply to: ↑ 14 Changed 5 years ago by hju@…

Replying to doki_pen:

Try with tracd and latest Trac.

sorry, what is tracd?
Testing with the newest Trac-Version will take a while because there is no update scheduled at the moment (and no installation so far)

Sorry that I can't help to reproduce this strange behaviour.
So far I use the "old version" of the plugin.

comment:16 Changed 5 years ago by doki_pen

Ok, well maybe it doesn't work with your version of trac. It is definitely working for me. What version of trac are you using? Maybe I can reproduce here.

comment:17 Changed 5 years ago by hju@…

Its a trac 0.11 from 10.07.2008

Till now no problems at all

comment:18 Changed 5 years ago by anonymous

This issue is also happening for me. Here's what I have listed on the Admin/Plugins page:

  • Trac 0.11
  • BatchModify 0.2.0
  • TracAccountManager 0.2.1dev-r3857
  • TracAddCommentMacro 0.3
  • TracDateField 1.0.1
  • TracGit 0.11.0.1
  • TracGitWeb 1.0
  • TracIncludePagesMacro 0.1
  • TracMacroPost 0.2
  • TracNav 4.0pre7
  • TracTags 0.6
  • TracTocMacro 11.0.0.3
  • TracVote 0.1
  • TracWikiNotification 0.2.0
  • TracWiki WYSIWYG Editor
  • !Tracticketsats 1.0

I installed with by creating an egg ( python setup.py bdist_egg ) and installing via the Admin page. I also restarted Trac, to no avail.

comment:19 Changed 5 years ago by anonymous

In Firefox and IE7, I am seeing the same error:

jquery-ui.js (line 133)
inst.dpDiv.outerWidth is not a function
[Break on this error] (function($){$.extend($.ui,{datepicker:{..."1.7.2";window.DP_jQuery=$})(jQuery);;/*

comment:20 Changed 5 years ago by doki_pen

  • Owner changed from doki_pen to anonymous
  • Status changed from new to assigned

Great! an error! I'll look into it tonight. Is jquery.js loaded for you? maybe another plugin is pulling jquery.js in for me and that's why I don't see the issue. I always thought trac included it, but maybe I'm wrong.

comment:21 Changed 5 years ago by doki_pen

This is my working jquery, what is yours?

/*
 * jQuery JavaScript Library v1.3.2
 * http://jquery.com/
 *
 * Copyright (c) 2009 John Resig
 * Dual licensed under the MIT and GPL licenses.
 * http://docs.jquery.com/License
 *
 * Date: 2009-02-19 17:34:21 -0500 (Thu, 19 Feb 2009)
 * Revision: 6246
 */

comment:22 Changed 5 years ago by anonymous

I'm seeing this:

/*
 * jQuery 1.2.3 - New Wave Javascript
 *
 * Copyright (c) 2008 John Resig (jquery.com)
 * Dual licensed under the MIT (MIT-LICENSE.txt)
 * and GPL (GPL-LICENSE.txt) licenses.
 *
 * $Date: 2008-02-06 00:21:25 -0500 (Wed, 06 Feb 2008) $
 * $Rev: 4663 $
 */

Looks like I have a very old version. How do I upgrade?

comment:23 Changed 5 years ago by anonymous

I went into my Trac install and replaced the old jQuery with jQuery 1.2.3 and the calendar icon now works as expected. Thanks for your help.

comment:24 Changed 5 years ago by doki_pen

But I'm interested in what version you have. Perhaps I can include jquery.js in the plugin and only invoke it if trac is older then X.

comment:25 follow-up: Changed 5 years ago by doki_pen

oh, I assume you mean 1.3.2.

comment:26 follow-up: Changed 5 years ago by doki_pen

Here is the fix changeset:7982. Apply the patch or upgrade trac to a revision above 7982.

comment:27 Changed 5 years ago by doki_pen

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:28 in reply to: ↑ 25 Changed 5 years ago by anonymous

Replying to doki_pen:

oh, I assume you mean 1.3.2.

Yes, I meant:

I went into my Trac install and replaced the old jQuery with jQuery 1.3.2 and the calendar icon now works as expected. Thanks for your help.

comment:29 in reply to: ↑ 26 Changed 4 years ago by tclugg

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to doki_pen:

Here is the fix changeset:7982. Apply the patch or upgrade trac to a revision above 7982.

...or something could be done to make this plugin work with jQuery 1.2.3 which is what is included in the latest stable release of Trac (0.11.7).

I suggest that r6118 should be backed out - it was applied to fix #1726 but looks like it is a regression that caused this issue.

comment:30 Changed 4 years ago by anonymous

jQuery 1.2.6 is packaged with trac 0.11.7.

comment:31 Changed 4 years ago by doki_pen

  • Owner changed from anonymous to doki_pen
  • Status changed from reopened to new

comment:32 Changed 4 years ago by doki_pen

I've testing with a fresh tags/trac-0.11.7 checkout and it works. Is you distro patching trac and setting the jquery.js to version 1.2.3?

comment:33 Changed 4 years ago by anonymous

My mistake - Trac does indeed use jQuery 1.2.6. A colleague had taken a copy of trac/htdocs quite some time ago from an older Trac release and directed Apache to use that (stale) copy. >:(

I'll try again after fixing our Trac install out-of-hours this evening. Will report back tomorrow.

comment:34 Changed 3 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Closing this very old ticket because I think this is working fine now with 0.11.7 and 0.12.x. Please reopen if you have more info.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from doki_pen. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.