Modify

Opened 5 years ago

Closed 3 years ago

#5472 closed defect (worksforme)

Permission limitation after user registration, but not with acct_mgr user admin web_ui

Reported by: luguolei@… Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: user verify needinfo permission
Cc: gunnar Trac Release: 0.11

Description

I installed AccountAdminPlugin,0.2.1dev_r0-py2.5 on Trac 0.11 use htpasswdstore.

Before registering the user full name and email, everything works fine. After the name and email information is saved(from a user preferences page), the account can login but the wiki,source browsing, ticket...everything can not work in Trac any more. The following information was displayed:

  Warning: <acct_mgr.web_ui.MessageWrapper object at 0x027BF6B0> 
  Error: Forbidden
  WIKI_VIEW privileges are required to perform this operation on WikiStart

I can only delete the acount and create a new one without user full name and email to recover.

If user full name and email address was filled at administration-accounts-users page, the user can see wiki page just after the first login. Once switch to other page, the save error occurs.

Here is my componets configurations in trac.ini:

[components]
acct_mgr.admin.accountmanageradminpage = enabled
acct_mgr.api.accountmanager = enabled
acct_mgr.db.sessionstore = disabled
acct_mgr.htfile.htpasswdstore = enabled
acct_mgr.notification.accountchangelistener = enabled
acct_mgr.notification.accountchangenotificationadminpanel = enabled
acct_mgr.pwhash.htpasswdhashmethod = enabled
acct_mgr.web_ui.accountmodule = enabled
acct_mgr.web_ui.emailverificationmodule = enabled
acct_mgr.web_ui.loginmodule = enabled
trac.web.auth.loginmodule = disabled

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by anonymous

  • Component changed from SELECT A HACK to AccountManagerPlugin

comment:2 Changed 5 years ago by luguolei@…

sorry it should be AccountManagerPlugin.

comment:3 Changed 5 years ago by pacopablo

  • Owner changed from mgood to pacopablo
  • Status changed from new to assigned

First, update to the latest trunk of account manager.

Second, unless you want to use email verification, turn off the email verification module in trac.ini

acct_mgr.web_ui.emailverificationmodule = disabled

comment:4 Changed 4 years ago by hasienda

  • Keywords verify needinfo permission added; full name email removed
  • Summary changed from Full name and email information register problem! to Permission limitation after user registration, but not with acct_mgr user admin web_ui

I think too, this is related to the verification module, even if you don't mention it at all.

Is this issue resolved? Without additional information we may think so and close this ticket soon.

comment:5 follow-up: Changed 4 years ago by hasienda

  • Owner changed from pacopablo to hasienda
  • Priority changed from high to normal
  • Status changed from assigned to new

I can't reproduce with current trunk version and Trac 0.12 right now.

For me behavior is always identical regardless of the registration by user or via admin web_ui: Verification token is sent on fist login and permissions are limitted right after this. There is no permission error or problem as was initially reported.

Looks like a local installation/configuration issue. You better show this is an issue to a specific version of AccountManagerPlugin or limited to applications with Trac <= 0.11 or something similar.

Hereby I set a timeout for responses to clarify open questions by the reporter to the end of this year taking the long time of virtually non-existing support into account. Furthermore I decrease priority and suspend any further actions until then.

comment:6 in reply to: ↑ 5 Changed 3 years ago by hasienda

  • Resolution set to worksforme
  • Status changed from new to closed

Replying to hasienda:

![...] Looks like a local installation/configuration issue. You better show this is an issue to a specific version of AccountManagerPlugin or limited to applications with Trac <= 0.11 or something similar.

Hereby I set a timeout for responses to clarify open questions by the reporter to the end of this year taking the long time of virtually non-existing support into account. Furthermore I decrease priority and suspend any further actions until then.

I guess, this was plenty much time for a response. There has been none. So it's reasonable to assume, that this is no longer an issue.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.