Modify

Opened 5 years ago

Closed 5 years ago

#5477 closed defect (duplicate)

Plugin not visible in the Menu selection

Reported by: davide.frignati@… Owned by: eblot
Priority: normal Component: RevtreePlugin
Severity: normal Keywords: Menu selection
Cc: Trac Release: 0.11

Description

I've installed the plugin and update the trac.it within [components] with revtree=*.enabled and within [trac] with repository_tpye = snv and base_url with the position of the trac project where folders "attachemnts,conf,db,htdocs,log,plugins,....." are

The problem is that I cannot find the Menu selection.
Where I've made installation wrong?

Thanks

Attachments (0)

Change History (15)

comment:1 Changed 5 years ago by eblot

There are a LOT of typos in your description. Can you please fix them?

Please copy here the changes (and only them) you made to trac.ini, from the description it seems you mixed and matched unrelated configuration options.

comment:2 Changed 5 years ago by anonymous

Modification done in trac.ini:

[components]
revtree.* = enabled

[trac]
repository_type = svn
base_url =
sdfg1\Elec_daily\trac\AgrotronSoftware

======================================================
the folder
sdfg1\Elec_daily\trac\AgrotronSoftware
contains the subfolder attachemnts,conf,db,htdocs,log,plugins,templates

comment:3 follow-up: Changed 5 years ago by davide.frignati@…

Modification done in trac.ini:

[components] revtree.* = enabled

[trac] repository_type = svn base_url =
sdfg1\Elec_daily\trac\AgrotronSoftware?

====================================================== the folder
sdfg1\Elec_daily\trac\AgrotronSoftware? contains the subfolder attachemnts,conf,db,htdocs,log,plugins,templates

comment:4 in reply to: ↑ 3 Changed 5 years ago by eblot

Replying to davide.frignati@sdfgroup.com:

[trac] repository_type = svn base_url = \\sdfg1\Elec_daily\trac\AgrotronSoftware

Not related to this issue, but \\sdfg1\Elec_daily\trac\AgrotronSoftware is not a URL, it is a Windows share path. Not a web standard, not supported. A valid URL should starts with either http:// or https://

Be sure to enable "DEBUG" trace level in Trac and verify within the debug traces that the Revtree plugin is actually loaded.

BTW: be sure to preview your comment before submitting it: the comment text box expects Wiki-formatted text.

comment:5 follow-up: Changed 5 years ago by davide.frignati@…

I've enabled the DEBUG trace and in the log file the plugin appears as installed.
On the plugin Menu I cannot see that the plug in is installed. Have I to give some permission?
I've installed the plugin version 0.6.3 since I'm using Trac 0.11
Sorry for my bad Wiki formatting, I'm new in this tool
Concerning windows share path, this is working for the allocation of the svn repository

comment:6 in reply to: ↑ 5 Changed 5 years ago by eblot

Replying to davide.frignati@sdfgroup.com:

On the plugin Menu I cannot see that the plug in is installed. Have I to give some permission?

You meant the plugin menu from the Administration panel, right?
No, you don't need special permission for the plugin to appear in this panel.
However, you need to give the REVTREE_VIEW permission to get the Revtree menu in the main menu bar.

I've installed the plugin version 0.6.3 since I'm using Trac 0.11

Right.

Concerning windows share path, this is working for the allocation of the svn repository

SVN repository needs a PATH, so it is correct.
base_url needs a URL.

PATH and URL are not the same kind of information.

comment:7 follow-ups: Changed 5 years ago by anonymous

Looking better at the log I can find :

2009-07-06 17:46:28,390 Trac[loader] DEBUG: Loading revtree.optimizer from c:\python25

2009-07-06 17:46:28,390 Trac[loader] ERROR: Skipping "revtree.optimizer = revtree.optimizer": (can't import "No module named revtree.optimizer")

2009-07-06 17:46:28,405 Trac[loader] DEBUG: Loading revtree.web_ui from c:\python25

2009-07-06 17:46:28,405 Trac[loader] ERROR: Skipping "revtree.web_ui = revtree.web_ui": (can't import "No module named revtree.web_ui")

2009-07-06 17:46:28,405 Trac[loader] DEBUG: Loading revtree.enhancer from c:\python25

2009-07-06 17:46:28,405 Trac[loader] ERROR: Skipping "revtree.enhancer = revtree.enhancer": (can't import "No module named revtree.enhancer")


It seem that the plugin is looking for something in c:\python25 that cannot be found

comment:8 in reply to: ↑ 7 Changed 5 years ago by eblot

Replying to anonymous:

Looking better at the log I can find

Tip: use block quoting / verbatim blocks to quote traces, it will save you a lot of hassle:
use {{{ `...` }}} where ... is the pasted text you want to quote.

comment:9 in reply to: ↑ 7 Changed 5 years ago by eblot

Replying to anonymous:

Looking better at the log I can find :

It seem that the plugin is looking for something in c:\python25 that cannot be found

It should not, there is an installation issue here but hard to diagnose.

How did you install the plugin exactly:

  • how did you retrieve it, how did you install it, how is configured you Trac setup?
  • have you defined the EGG cache directory?
  • have you installed any other plugin?

comment:10 follow-up: Changed 5 years ago by davide.frignati@…

Plugin was donwloaded from track-hacks
built with python
Installed with plugin intrface
EGG cache directory is for me unknow item
Other plugin are installed (excel report plugin, ticket import, etc...)

Wiki formatting is not so easy, WikiFormatting help page should have more examples

comment:11 in reply to: ↑ 10 ; follow-up: Changed 5 years ago by eblot

Replying to davide.frignati@sdfgroup.com:

Plugin was donwloaded from track-hacks

from svn or as a zip file?

EGG cache directory is for me unknow item

Then you should really consider reading Trac installation guide: wiki:TracPlugins#SettingupthePluginCache

comment:12 in reply to: ↑ 11 Changed 5 years ago by william

Hello Emmanuel, thanks for the support!!

There was an error during the build procedure so that we ended up with an empty egg actually! Now the main plugin is working, but we have a problem with the RevtreePlugin/MergeInfoEnhancer plugin.

The plugin builds and installs correctly and it works, unless we select a revision range that includes revision not shown in the (basic) revision graph.

For example we have

  • revision 7: deleted Branches/branch_xxx
  • revision 8: created Branches/branch_yyy

Both are not shown in the basic revision graph. If we enable the MergeInfoEnhancer plugin and we build the revision graph including this two revision we have an error

No node Branches/branch_xxx at revision 7

Both were empty branches. I have looked inside the code enhancer.py and I have seen the FIXME message related to empty branches. Can it be related?

comment:13 Changed 5 years ago by william.spinelli@…

  • Resolution set to fixed
  • Status changed from new to closed

It seems that the problem with the RevtreePlugin/MergeInfoEnhancer described above was similar to that of ticket #4837.

Applying the patch attachment:ticket:4837:deleted-branches.patch the problem was solved.

comment:14 Changed 5 years ago by eblot

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:15 Changed 5 years ago by eblot

  • Resolution set to duplicate
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.