Modify

Opened 8 years ago

Closed 8 years ago

#550 closed defect (fixed)

Error: 'cannot marshal None unless allow_none is enabled' while executing 'ticket.version.get()'

Reported by: steffenp@… Owned by: athomas
Priority: normal Component: XmlRpcPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.10

Description (last modified by athomas)

After setting up a fresh Trac repository and trying to fetch version information through the XmlRpcPlugin Trac displayed an error:

cannot marshal None unless allow_none is enabled

when executing ticket.version.get().

This is caused by the time field of the version which is set to NULL in the database.

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by athomas

  • Description modified (diff)

comment:2 Changed 8 years ago by athomas

  • Resolution set to fixed
  • Status changed from new to closed

(In [1070]) Fixes #550, #483, #530 and #411 (hopefully).

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.