Modify

Opened 5 years ago

Closed 5 years ago

#5622 closed defect (fixed)

ImageTracPlugin not listed on admin plugins page

Reported by: jevans Owned by: k0s
Priority: normal Component: ImageTracPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

I get further with the fix for #5596 but I don't see ImageTracPlugin listed in the admin plugins page.

I tried adding "imagetrac.* = enabled" to my trac.ini to no effect (is that the right component name?)

This is the output from the install.

C:\Programs\Python26\Scripts>easy_install http://trac-hacks.org/svn/imagetracplu
gin/0.11/
Downloading http://trac-hacks.org/svn/imagetracplugin/0.11/
Doing subversion checkout from http://trac-hacks.org/svn/imagetracplugin/0.11/ t
o c:\docume~1\jes\locals~1\temp\easy_install-uhgvle\0.11
Processing 0.11
Running setup.py -q bdist_egg --dist-dir c:\docume~1\jes\locals~1\temp\easy_inst
all-uhgvle\0.11\egg-dist-tmp-imc91y
imagetrac 0.2.1 is already the active version in easy-install.pth

Installed c:\programs\python26\lib\site-packages\imagetrac-0.2.1-py2.6.egg
Processing dependencies for imagetrac==0.2.1
Searching for PIL
Best match: PIL 1.1.6
Downloading http://dist.repoze.org/PIL-1.1.6.tar.gz
Processing PIL-1.1.6.tar.gz
Running PIL-1.1.6\setup.py -q bdist_egg --dist-dir c:\docume~1\jes\locals~1\temp
\easy_install-0n_lo6\PIL-1.1.6\egg-dist-tmp-ciyrjv
error: Setup script exited with error: None

Is the "error: Setup script exited with error: None" normal?

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by jevans

Taking a stab, I went to http://www.pythonware.com/products/pil/ and installed PIL 1.1.6 from there, and reinstalled ImageTracPlugin.

Now I see imagetrac 0.2.1 in the admin plugins page with all components enabled.

But I don't see images on tickets. Is there something else I need to configure? What image formats are supported?

comment:2 follow-up: Changed 5 years ago by jevans

I left it enabled and today as tickets are added, I see it is adding additional images when an image is added to a ticket - an imagename.32x32.gif and an imagename.488x.gif. It's only doing this for new tickets - existing tickets are unaffected.

The 32x32 image is shown in the sidebar. It looks like the 488x image is flashed for a fraction of a second when the 32x32 image is clicked.

What is the expected behavior?

I only see the one image listed in the example on ImageTracPlugin. Is there a way to hide or avoid adding the additional images?

comment:3 in reply to: ↑ 2 Changed 5 years ago by k0s

  • Resolution set to fixed
  • Status changed from new to closed

Replying to jevans:

I left it enabled and today as tickets are added, I see it is adding additional images when an image is added to a ticket - an imagename.32x32.gif and an imagename.488x.gif. It's only doing this for new tickets - existing tickets are unaffected.

That is correct. Ideally, images would be made (at least optionally) on an need-to-have basis, but currently it is only done for new tickets.

The 32x32 image is shown in the sidebar. It looks like the 488x image is flashed for a fraction of a second when the 32x32 image is clicked.

What is the expected behavior?

If the Galleria component is enabled (highly recommended, as there is a bug for the case when it is not), then the thumbnails should be displayed and clicking on them will show the image above the thumbnails.

I only see the one image listed in the example on ImageTracPlugin. Is there a way to hide or avoid adding the additional images?

Not currently, nope.

I've added a README which is rendered on the ImageTracPlugin wiki page. It at least tells what each component is for and does, but its not very detailed. The ImageTracPlugin is a work in progress and I probably won't be able to fix the bugs in it until it is more of an organizational priority here.

Add Comment

Modify Ticket

Action
as closed The owner will remain k0s.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.