Modify

Opened 5 years ago

Closed 20 months ago

Last modified 4 months ago

#5691 closed defect (fixed)

No cookie warning shown when trying to log in with Konqueror

Reported by: sascha_silbe Owned by: hasienda
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords: needinfo redirect
Cc: Trac Release: 0.11

Description

When trying to log in to dev.sugarlabs.org (running Trac 0.11.1 with AccountManager 0.2.1dev-r4679) with cookies disabled and using w3m, the
following error is shown:

Error: Bad Request

Missing or invalid form token. Do you have cookies enabled?

But with Konqueror the page shown prior to login will be shown (like it does if login is
successful), again with no credentials (i.e. it offers to login again). No error message, no
warning about missing cookies. This has confused one of our users.

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by hasienda

  • Keywords needinfo redirect added
  • Owner changed from pacopablo to hasienda
  • Summary changed from no cookie warning shown when trying to log in with Konqueror to No cookie warning shown when trying to log in with Konqueror

Are you be able to check with a recent version from trunk?

Please checkout [9263], since that changeset seems to be related, or any later revision. I'm looking forward to getting feedback about your experiences.

comment:2 Changed 20 months ago by hasienda

In absence of any feedback I'll treat this as fixed by changes do to significantly improve auth cookie handling during this year.

comment:3 Changed 20 months ago by hasienda

  • Resolution set to fixed
  • Status changed from new to closed

(In [12398]) AccountManagerPlugin: Releasing version 0.4, pushing development to acct_mgr-0.5dev.

Availability of that code as stable release
closes #874, #3459, #4677, #5295, #5691, #6616, #7577, #8076, #8685, #8770, #8791, #8990, #9052, #9079, #9090, #9139, #9246, #9252, #9547, #9618, #9676, #9843, #9852, #9940, #10023, #10028, #10123, #10142, #10204, #10276, #10397, #10412, #10594, #10625 and #10644.

Some more issues have been worked-on, yet without confirmed resolution,
refs #5464 (for JiraToTracIntegration), #8927 and #10134.

And finally there are some issues and enhancement requests showing progress,
but known to require more work to resolve them satisfactorily,
refs #843, #1600, #5964, #8217, #8933.

Thanks to all contributors and followers, that enabled and encouraged a good
portion of this development work.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from hasienda. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.