Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5738 closed defect (fixed)

Apache error after easy_install the new version

Reported by: webmaster@… Owned by: echo0101
Priority: high Component: TracTicketStatsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

hey guys. I wanted to try the new version of that feature, because the olde one destroyed my customized mainnav.

I downloaded the source, compiled it with 'python setup.py bdist_egg' and installed the created egg file with easy_install.

After restarting my apache, i could access any of my projects... not even the index-page...

A view into the error.log of apache showed:

[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     import trac.web.main
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/Trac-0.11.4-py2.5.egg/trac/__init__.py", line 14, in <module>
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     __version__ = __import__('pkg_resources').get_distribution('Trac').version
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2581, in <module>
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     add_activation_listener(lambda dist: dist.activate())
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 640, in subscribe
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     callback(dist)
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2581, in <lambda>
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     add_activation_listener(lambda dist: dist.activate())
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2127, in activate
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     self.insert_on(path)
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2223, in insert_on
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     self.check_version_conflict()
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2262, in check_version_conflict
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     for modname in self._get_metadata('top_level.txt'):
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 2121, in _get_metadata
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     for line in self.get_metadata_lines(name):
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1140, in get_metadata_lines
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     return yield_lines(self.get_metadata(name))
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1137, in get_metadata
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     return self._get(self._fn(self.egg_info,name))
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]   File "/usr/lib/python2.5/site-packages/pkg_resources.py", line 1195, in _get
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172]     return self.loader.get_data(path)
[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172] IOError: zipimport: can not open file /usr/lib/python2.5/site-packages/Tracticketstats-2.1-py2.5.egg

I had to deinstall it and restart again to get access to my projects...

Any hints or help regarding that?

kind regards
meneke

notes:
Trac Version: 0.11.4
Python 2.5

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by echo0101

  • Status changed from new to assigned

I'm not really sure what the problem is. We're running trac 11.4 w/ py2.5 too.

From the last line of your error log:

[Fri Aug 28 10:29:24 2009] [error] [client 192.168.128.172] IOError: zipimport: can not open file /usr/lib/python2.5/site-packages/Tracticketstats-2.1-py2.5.egg

sounds like maybe your app doesnt have permission to read the file or something? Maybe try doing the bdist_egg and dropping the egg in your trac plugins directory instead of installing to site packages.

You might also try doing sudo python setup.py install (though that should essentially do the same thing as bdist_egg + setup_tools (i think).

comment:2 follow-up: Changed 5 years ago by anonymous

  • Resolution set to fixed
  • Status changed from assigned to closed

hmm thx...

now its working and all is fine :-)

the reason was: the created egg-file had NO Permission to nobody (000), although i created the egg as root!!

a chmod +rw to the egg file before easy_install and the apache is still running :-)

and my customized mainnav is still there and clickable :-)

thx 4 the hint :-)
kind regards
meneke

comment:3 in reply to: ↑ 2 Changed 5 years ago by anonymous

And also i had to delete the version v1 of that plugin... an upgrade broke the apache too. dont ask me why
im glad its working now :-)

time to test the next plugin

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from echo0101. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.