Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#5764 closed defect (fixed)

Installation Upgrade Failure

Reported by: matthew.blackford@… Owned by: bobbysmith007
Priority: normal Component: NeverNotifyUpdaterPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

The following installation steps produce an error:

  1. Correctly installed the plugin using the standard procedure (confirmed that the egg file exists in the Python26\Lib\site-packages directory
  2. Configured the components section of the ini file to include nevernotifyupdaterplugin.* = enabled
  3. Ran trac-admin path/to/project upgrade
  4. The following error is produced:
    C:\apps\Python26\Scripts>trac-admin c:/apps/trac/sandbox upgrade
    Traceback (most recent call last):
      File "C:\apps\Python26\Scripts\trac-admin-script.py", line 8, in <module>
        load_entry_point('Trac==0.11.5', 'console_scripts', 'trac-admin')()
      File "C:\apps\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\adm
    n\console.py", line 1314, in run
        return admin.onecmd(command)
      File "C:\apps\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\adm
    n\console.py", line 133, in onecmd
        rv = cmd.Cmd.onecmd(self, line) or 0
      File "C:\apps\Python26\lib\cmd.py", line 219, in onecmd
        return func(arg)
      File "C:\apps\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\adm
    n\console.py", line 1149, in do_upgrade
        if not self.__env.needs_upgrade():
      File "C:\apps\Python26\lib\site-packages\trac-0.11.5-py2.6-win32.egg\trac\env
    py", line 429, in needs_upgrade
        if participant.environment_needs_upgrade(db):
    AttributeError: 'NeverNotifyUpdaterSetupParticipant' object has no attribute 'e
    vironment_needs_upgrade'
    

As a test I modified one of my own tickets and still received an email.

Attachments (0)

Change History (5)

comment:1 Changed 5 years ago by raa

Same for me

Traceback (most recent call last):

File "/home/ewa/trac/env/bin/trac-admin", line 8, in <module>

load_entry_point('Trac==0.11.4', 'console_scripts', 'trac-admin')()

File "/home/ewa/trac/env/lib/python2.6/site-packages/trac/admin/console.py", line 1317, in run

return admin.onecmd(command)

File "/home/ewa/trac/env/lib/python2.6/site-packages/trac/admin/console.py", line 133, in onecmd

rv = cmd.Cmd.onecmd(self, line) or 0

File "/usr/local/lib/python2.6/cmd.py", line 219, in onecmd

return func(arg)

File "/home/ewa/trac/env/lib/python2.6/site-packages/trac/admin/console.py", line 1149, in do_upgrade

if not self.env.needs_upgrade():

File "/home/ewa/trac/env/lib/python2.6/site-packages/trac/env.py", line 430, in needs_upgrade

if participant.environment_needs_upgrade(db):

AttributeError: 'NeverNotifyUpdaterSetupParticipant' object has no attribute 'environment_needs_upgrade'

comment:2 Changed 5 years ago by bobbysmith007

sorry for the delay, I dont always get my notifications from trachacks.

There will be a fix pushed momentarily (testing now)

comment:3 Changed 5 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

(In [6512]) fixes #5764 about not having fleshed out the interface all the way

comment:4 Changed 5 years ago by anonymous

thank you

comment:5 Changed 5 years ago by bobbysmith007

your welcome :)

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.