Modify

Opened 5 years ago

Closed 4 years ago

#5767 closed defect (wontfix)

Comments inserted by MailToTracPlugin can't be edited

Reported by: anonymous Owned by: rjollos
Priority: high Component: TicketChangePlugin
Severity: normal Keywords:
Cc: listman@… Trac Release: 0.11

Description (last modified by rjollos)

i use the email2trac plugin to allow users to comment on tickets via email. this attaches the email text between { } formatting brackets in the email comments. when i try to edit these i get: Ticket change '5' not found. Please try again

can we fix this plugin to work with comments inside { }. thats where the majority of our comments come from because of our use of email2trac

thx

Attachments (0)

Change History (13)

comment:1 Changed 5 years ago by anonymous

  • Cc listman@… added; listman@… removed

comment:2 Changed 5 years ago by rjollos

  • Cc rjollos added

comment:3 Changed 5 years ago by rjollos

There has been some recent activity on integrating this feature directly into Trac: http://trac.edgewall.org/ticket/454

Hopefully that happens soon!

comment:4 Changed 5 years ago by rjollos

  • Cc rjollos removed
  • Summary changed from trying to edit a comment with {....} formatting doesn't work consistently to Editing a comment with {....} formatting doesn't work consistently

comment:5 in reply to: ↑ description ; follow-up: Changed 5 years ago by rjollos

Replying to anonymous:

i use the email2trac plugin to allow users to comment on tickets via email. this attaches the email text between { } formatting brackets in the email comments. when i try to edit these i get: Ticket change '5' not found. Please try again

This may be related to an issue I'm seeing with the TracBacksPlugin (#6535).

comment:6 in reply to: ↑ 5 Changed 5 years ago by rjollos

Replying to rjollos:

Replying to anonymous:

i use the email2trac plugin to allow users to comment on tickets via email. this attaches the email text between { } formatting brackets in the email comments. when i try to edit these i get: Ticket change '5' not found. Please try again

This may be related to an issue I'm seeing with the TracBacksPlugin (#6535).

After further testing, I've found that I can't edit ANY ticket comments generated by the TracBacksPlugin, so the scope of that issue is beyond just those comments with formatting brackets.

comment:7 in reply to: ↑ description Changed 5 years ago by rjollos

Replying to anonymous:

i use the email2trac plugin to allow users to comment on tickets via email. this attaches the email text between { } formatting brackets in the email comments. when i try to edit these i get: Ticket change '5' not found. Please try again

When you say that the comments are between { } formatting brackets, do you mean enclosed in {{{ and }}}?

comment:8 Changed 5 years ago by steve.strobel@…

This issue probably has the same root cause as the one I reported in Ticket #6930 (Can't edit comments added through Mylyn).

comment:9 Changed 4 years ago by rjollos

See #6535 for additional comments on the issue.

comment:10 Changed 4 years ago by rjollos

  • Owner changed from SergeiLuchko to rjollos
  • Status changed from new to assigned

comment:11 Changed 4 years ago by rjollos

Unless we figure out a way to do things better in the TicketChangePlugin, the email2trac plugin will need to be modified to fix this issue. For details, see comment:3:ticket:6535.

comment:12 Changed 4 years ago by rjollos

  • Summary changed from Editing a comment with {....} formatting doesn't work consistently to Comments inserted by MailToTracPlugin can't be edited

Do you mean MailToTracPlugin or EmailtoTracScript? I can look into working up a patch.

comment:13 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Resolution set to wontfix
  • Status changed from assigned to closed

Closing as wontfix since the plugin is deprecated. I'd apply a patch if it was made available.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.