Modify

Opened 5 years ago

Closed 4 years ago

#5815 closed defect (fixed)

Login problem

Reported by: myersjj@… Owned by: mgood
Priority: normal Component: AccountManagerPlugin
Severity: normal Keywords:
Cc: michael@… Trac Release: 0.11

Description

I have istalled AccountManager into TRAC 11.5 and it seems to work fine except for 1 user who can login, but then can't do anything because permissions aren't recognized.
This message shows in a yellow bar near the top of the page:

Warning: <acct_mgr.web_ui.MessageWrapper object at 0xb7b0a28c>

This user has correct password and is authorized for WIKI_ADMIN, yet this message also appears in red bar below yellow bar mentioned above...

WIKI_VIEW privileges are required to perform this operation on WikiStart

Relevant lines from TRAC log...

2009-09-14 00:08:49,972 Trac[perm] INFO: Granted permission for WIKI_ADMIN to jmadams
2009-09-14 00:08:50,582 Trac[env] WARNING: base_url option not set in configuration, generated links may be incorrect
2009-09-14 00:08:57,999 Trac[env] WARNING: base_url option not set in configuration, generated links may be incorrect
2009-09-14 00:08:58,079 Trac[main] WARNING: HTTPForbidden: 403 Forbidden (WIKI_VIEW privileges are required to perform this operation on WikiStart)

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by anonymous

  • Cc michael@… added

comment:2 Changed 5 years ago by myersjj@…

Turns out the failure was the result of the new user not having yet confirmed his email address. Still there is a problem with the strange message being issued under this circumstance.

comment:3 Changed 4 years ago by pacopablo

  • Resolution set to fixed
  • Status changed from new to closed

please use the latest trunk or 0.11 version of account manager, this bug should be fixed.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from mgood. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.