Modify

Opened 5 years ago

Closed 5 years ago

#5934 closed defect (fixed)

Access denied

Reported by: didley@… Owned by: makadev
Priority: normal Component: ProjectPlanPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

If I using your plugin for example with

  • [[ProjectPlan(renderer=gvrender,macroid=2,withbuffer)]]

I got this error log.

Traceback (most recent call last):
  File "c:\programme\python25\lib\site-packages\Trac-0.11.5-py2.5.egg\trac\wiki\formatter.py", line 480, in _macro_formatter
    return macro.process(args, in_paragraph=True)
  File "c:\programme\python25\lib\site-packages\Trac-0.11.5-py2.5.egg\trac\wiki\formatter.py", line 180, in process
    text = self.processor(text)
  File "c:\programme\python25\lib\site-packages\Trac-0.11.5-py2.5.egg\trac\wiki\formatter.py", line 167, in _macro_processor
    text)
  File "build\bdist.win32\egg\projectplan\projectplan.py", line 204, in expand_macro
    ppRender().render( macroenv, ts ),
  File "build\bdist.win32\egg\projectplan\pprender.py", line 863, in render
    return ConcreteRenderer( macroenv ).render( ticketset )
  File "build\bdist.win32\egg\projectplan\pprender.py", line 587, in render
    self._cmapxgenerate( ticketset )
  File "build\bdist.win32\egg\projectplan\pprender.py", line 475, in _cmapxgenerate
    self.cmapxgen.generate()
  File "build\bdist.win32\egg\projectplan\dotrender.py", line 103, in generate
    stderr = subprocess.STDOUT )
  File "C:\Programme\Python25\Lib\subprocess.py", line 594, in __init__
    errread, errwrite)
  File "C:\Programme\Python25\Lib\subprocess.py", line 822, in _execute_child
    startupinfo)
WindowsError: [Error 5] Zugriff verweigert (Access denied)

I'm using

TRAC:           0.11.5
Python: 	2.5.4 (r254:67916, Dec 23 2008, 15:10:54) [MSC v.1310 32 bit (Intel)]
setuptools: 	0.6c9
SQLite: 	3.3.4
pysqlite: 	2.3.2
Genshi: 	0.5.1
Subversion: 	1.5.6 (r36142)
Pygments: 	1.0
RPC: 	1.0.6
Agilo: 	0.8.0-RC2-r1719-20090719
SilverCity: 	0.9.7
jQuery:	1.2.6

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by makadev

  • Status changed from new to assigned

Thanks for the Report,

I need additonal information about your setup:
Please Verify the following Settings

  • in your Trac, loggin with administrative Rights, navigate to Admin (WebAdmin)
    • Select the Panel ProjectPlan -> General Settings (on the left)
    • Verify your settings for cachepath and dot_executable
  • or set the following options with your pathes in the projects trac.ini
    [pp_options]
    cachepath = <temporary path>\ppcache
    dot_executable = <path>\dot.exe
    
    • restart your websever for configuration reloading

Please Report again, if its already setup correctly or working after Configuration.

comment:2 Changed 5 years ago by didley@…

Thank's for your return.

I played around with the configuration yesterday.

If I remove dot_executable path I got the message " system can't find the path". That's ok. If I put in the correct path I get the message "WindowsError: [Error 5] Zugriff verweigert (Access denied)".

It seems there are not the correct access rights. But I'm using Graphviz with a cmd_path also. And graphviz works.

The next thing is that I can't put in a value in the due_assign.value and the due_close.value field. Always after a input of a date value and pressing the button apply change my input is replaced with DD/MM/YYYY.

didley

comment:3 Changed 5 years ago by makadev

Hi,

I setup a Windows Test System (trac 0.11.5 on Windows XP SP3, python 2.5) and fixed 2 major bugs in file/process handling for windows. But i cant reproduce the Access Denied Issue.

For the Second thing, there are 3 possible Formats at the moment. This is set to selectable in rev6664.

comment:4 Changed 5 years ago by didley@…

Hi,

I changed to the new rev6664 and the format for the date works now. But I did have always the message (access denied).

After this I did the following: I changed the path input from

  • X:\XXX\...\Graphviz2.24\bin

to

  • X:\XXX\...\Graphviz2.24\bin\dot.exe

Now it works.

Thank's for your help.

Best regrads

didley

comment:5 Changed 5 years ago by makadev

Thanks for your Reply,

I'll add a check for problems like this.

comment:6 Changed 5 years ago by makadev

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6668]) added dot executable check for absolute pathes, closes #5934

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from makadev. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.