Modify

Opened 5 years ago

Closed 5 years ago

#5939 closed defect (fixed)

No or not functional ticket attributes

Reported by: smaug@… Owned by: makadev
Priority: normal Component: ProjectPlanPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

When I install the plugin enable it in 'Admin' window and restart web server, no additional ticket attributes appears in 'New Ticket' window. So I tried to inspect the source code (although I have very low knowledge of Python) and add them manually in 'trac.ini' like for similar plugins:

[ticket-custom]
startdate = text
startdate.label = Start Date
finishdate = text
finishdate.label = Finish Date
buffer = text
buffer.label = Buffer
dependencies = text
dependencies.label = Dependencies
reverse_dependencies = text
reverse_dependencies.label = Reverse Dependencies

Now I can assign that attributes, but the only one that seems to be functional and has an effect in macros is 'dependencies' (not 'reverse_dependencies' not any other).

My Trac instalation:

Trac:  	0.11.5
Python: 	2.5.2 (r252:60911, Jan 4 2009, 18:00:02) [GCC 4.3.2]
setuptools: 	0.6c9
SQLite: 	3.5.9
pysqlite: 	2.4.1
Genshi: 	0.5.1
mod_python: 	3.3.1
Pygments: 	0.10
Subversion: 	1.5.1 (r32289)
jQuery:	1.2.6

OS: Linux (Debian Lenny)

I hope, I'm doing something wrong and it's not a bug, but it seems to be.

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by makadev

  • Severity changed from normal to major
  • Status changed from new to assigned

Thanks for the Report,

It is a Bug (more or less, a documentation bug), which results from my Testing System and the "not yet" completed Documentation about Installation and Configuration.

The correct Ticket-Custom setup is:

[ticket-custom]
dependencies = text
dependencies.label = Dependencies
due_assign = text
due_assign.label = Due to assign
due_assign.value = DD/MM/YYYY
due_close = text
due_close.label = Due to close
due_close.value = DD/MM/YYYY

The fields you added are part of temporary values, calculated in the plugin. You can remove them, because they are calculated when needed and never saved or retrived from the Database.

I'll add these to the "Basic Setup" wiki part and INSTALL file.

comment:2 Changed 5 years ago by makadev

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [6658]) added basic/first configuration part to INSTALL, closes #5939

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.