Modify

Opened 5 years ago

Closed 7 months ago

#5950 closed defect (worksforme)

Chosen theme string is treated as case-sensitive

Reported by: ccockrell@… Owned by: olemis
Priority: normal Component: ThemeEnginePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I am using Ubuntu Server (9.04) and Trac 0.11.1.

I installed the ThemeEngine plugin and a handful of themesfrom the source using easy_install, enabled them all, restarted the web server - all ok.

But when I chose a theme using the webadmin page, a message appeared saying that the "theme could not be found, check that the theme plugin has been enabled". The problem turned out to be the case of the theme name under the trac.ini [theme] section.

So, if I selected CrystalX, the automatically generated string of 'Crystalx' caused the error, but when I manually altered it to 'CrystalX' the theme worked.

I installed crystalx, pydotorg, gnomebr, gamedev, moveabletypeskin themes, and the only one that worked out of the box was gamedev.

Crystalx should be CrystalX
Gnomebr should be GnomeBR
Moveabletypeskin should be MoveableTypeSkin
Pydotorg should be PyDotOrg

I reported it against the themeengine because it happens with a number of themes, so I am not sure where the problem lies.

Attachments (0)

Change History (4)

comment:2 Changed 5 years ago by mkc

To give more information on this, it appears that the theme name gets written title-cased to the trac.ini file (e.g. GnomeBR -> Gnomebr, default -> Default).

Gamedev works because the internal theme name happens to match this capitalization.

comment:3 Changed 5 years ago by mkc

http://trac-hacks.org/ticket/2958 seems to resolve this.

comment:4 Changed 7 months ago by olemis

  • Owner changed from coderanger to olemis

comment:5 Changed 7 months ago by olemis

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce the issue running recent versions of the plugin . Feel free to reopen this ticket if failure is detected .

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from olemis. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.