Modify

Opened 5 years ago

Closed 18 months ago

Last modified 18 months ago

#5970 closed defect (worksforme)

No sidebar displayed

Reported by: adebruyn Owned by: rjollos
Priority: highest Component: TicketMoverPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.11

Description

On a fresh Trac 0.11.5 install, the TicketMoverPlugin sidebar is not displayed in the (new|accepted) ticket page.

The SampleTicketSidebarProvider is working.

I had installed TicketMoverPlugin via easy_install :

easy_install http://trac-hacks.org/svn/ticketmoverplugin/0.11/

with no issue apparently :

Downloading http://trac-hacks.org/svn/ticketmoverplugin/0.11/
Doing subversion checkout from http://trac-hacks.org/svn/ticketmoverplugin/0.11/ to /tmp/easy_install-rRsnlF/0.11
Processing 0.11
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-rRsnlF/0.11/egg-dist-tmp-EsBoa-
Adding TicketMoverPlugin 0.1.1 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/TicketMoverPlugin-0.1.1-py2.5.egg
Processing dependencies for TicketMoverPlugin==0.1.1
Searching for TracSQLHelper
Best match: TracSQLHelper [unknown version]
Downloading http://trac-hacks.org/svn/tracsqlhelperscript/anyrelease#egg=TracSQLHelper
Doing subversion checkout from http://trac-hacks.org/svn/tracsqlhelperscript/anyrelease to /tmp/easy_install-ntG6pV/anyrelease
Processing anyrelease
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-ntG6pV/anyrelease/egg-dist-tmp-hseZHq
Adding TracSQLHelper 0.2.1 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/TracSQLHelper-0.2.1-py2.5.egg
Searching for TicketSidebarProvider
Best match: TicketSidebarProvider [unknown version]
Downloading http://trac-hacks.org/svn/ticketsidebarproviderplugin/0.11#egg=TicketSidebarProvider
Doing subversion checkout from http://trac-hacks.org/svn/ticketsidebarproviderplugin/0.11 to /tmp/easy_install-9PgKKB/0.11
Processing 0.11
Running setup.py -q bdist_egg --dist-dir /tmp/easy_install-9PgKKB/0.11/egg-dist-tmp-U2SZQ0
Adding TicketSidebarProvider 0.0 to easy-install.pth file

Installed /usr/lib/python2.5/site-packages/TicketSidebarProvider-0.0-py2.5.egg
Finished processing dependencies for TicketMoverPlugin==0.1.1

The plugin is enabled in the configuration file (and visible via the Trac admin/plugins panel) :

[components]
ticketmoverplugin.ticketmover.ticketmover = enabled
ticketmoverplugin.web_ui.ticketmoverhandler = enabled
ticketmoverplugin.web_ui.ticketmoversidebar = enabled
ticketsidebarprovider.example.sampleticketsidebarprovider = disabled
ticketsidebarprovider.ticketsidebar.ticketsidebarprovider = enabled

Authenticated users have the TICKET_ADMIN permission (not working with TRAC_ADMIN either).

There is no errors reported in the Trac log file (in DEBUG mode).

Attachments (1)

sidebar.png (26.8 KB) - added by dak@… 5 years ago.
ticketmover sidebar

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by dak@…

Confirmed for me too. Trac 0.11.5 but no sidebar. I think the problem here is the sidebar plugin, not ticketmover.

comment:2 Changed 5 years ago by dak@…

(sorry, didn't notice who created the ticket)

Changed 5 years ago by dak@…

ticketmover sidebar

comment:3 Changed 5 years ago by dak@…

Hi, I noticed that the TicketMover sidebar HTML is generated but placed at the bottom of a ticket page:

<div class="sidebar"> 
  <form action="/SpecialOps/ticket/move" method="post"><div><input type="hidden" name="__FORM_TOKEN" value="2b58b20073be9b471441527f" /></div> 
    <div> 
      Move ticket to
      <span> 
        udvikling
        <input type="hidden" name="project" value="udvikling" /> 
      </span> 
    </div> 
    <div> 
      <input type="checkbox" name="delete" value="delete" /> Delete this ticket from the database
    </div> 
    <div> 
      <input type="hidden" name="ticket" value="448" /> 
      <input type="submit" value="Move" /> 
    </div> 
  </form> 
</div> 

comment:4 Changed 4 years ago by sparrow

  • Priority changed from high to highest

the same problems:

  • no sidebar displayed
  • example sidebar rendered at the bottom of the page
  • the mover plugin not displayed in web admin

comment:5 Changed 4 years ago by sparrow

forgot to mention - my trac version is 0.12.2

comment:6 Changed 3 years ago by sparrow

When I manually copied css file into htdocs the sidebar appeared correctly. I have also installed the plugin with easy_install and link the egg folder symbolically into my trac plugins folder and the mover started to work! Beforehand I copied the egg into plugins folder and it was not seen by trac.

comment:7 Changed 18 months ago by rjollos

  • Owner changed from k0s to rjollos
  • Status changed from new to assigned

comment:8 Changed 18 months ago by rjollos

  • Resolution set to worksforme
  • Status changed from assigned to closed

It seems to be working fine for me. I added a debug-level logging statement that should help with diagnosing problems.

In order for the sidebar to appear:

  • There must be at least one other project in the same directory. For example, if the Trac environment you are trying to move a ticket from is /var/trac/env1, the other environment must also reside in /var/trac/.
  • You must have [ticket] move_permission for both the source and destination environments.

Please reopen if you continue to have trouble and would like help with debugging.

comment:9 Changed 18 months ago by rjollos

(In [13215]) Refs #5970: Add DEBUG level log entry when ITicketSidebarProvider entry is enabled or disabled.

Add Comment

Modify Ticket

Action
as closed The owner will remain rjollos.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.