Modify

Opened 5 years ago

Closed 4 years ago

Last modified 18 months ago

#5973 closed defect (fixed)

Cannot handle Trac databases with non-ascii (unable to save changes on any ticket containing non-ascii chars)

Reported by: anonymous Owned by: bjornharrtell
Priority: normal Component: GridModifyPlugin
Severity: normal Keywords:
Cc: sth@…, eduardo.jose.pereira@… Trac Release: 0.11

Description

As soon as i changed a value in ticket list, the ajax request get a failure.

Details as follows:

Oops...
Traceback (most recent call last):

File "build/bdist.linux-i686/egg/gridmod/web_ui.py", line 69, in process_request

UnicodeEncodeError: 'ascii' codec can't encode character u'\xfc' in position 22: ordinal not in range(128)

Attachments (0)

Change History (7)

comment:1 Changed 4 years ago by eduardo.jose.pereira@…

  • Cc eduardo.jose.pereira@… added

Is there a workaround for this problem?

comment:2 Changed 4 years ago by anonymous

Got the same issue, but cannot reproduce it reliably :/

comment:3 Changed 4 years ago by anonymous

  • Summary changed from Fatal error while saving changes to Fatal error while saving changes (unicode encode error, i.e affects non-ascii users)

Verified now, reproducable only on tickets that have fields/data containing non-ascii characters.

Funny thing is, it's the debug logging that causes the problem. Commenting out debug log stuff in web_ui.py (specifically line 69) seem to fix the issue.

comment:4 Changed 4 years ago by anonymous

  • Summary changed from Fatal error while saving changes (unicode encode error, i.e affects non-ascii users) to Cannot handle Trac databases with non-ascii (unable to save changes on any ticket containing non-ascii chars)

Changed summary to better describe the problem

comment:5 Changed 4 years ago by anonymous

  • Owner changed from abbywinterscom to anonymous
  • Status changed from new to assigned

comment:6 Changed 4 years ago by bjornharrtell

  • Owner changed from anonymous to bjornharrtell
  • Status changed from assigned to new

comment:7 Changed 4 years ago by bjornharrtell

  • Resolution set to fixed
  • Status changed from new to closed

(In [8327]) Replaced string concatenation with substuition for the logging (closes #5973)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bjornharrtell. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.