Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#6062 closed defect (worksforme)

user in CC list, usernames separated by space --> unable to access ticket

Reported by: nenad@… Owned by: coderanger
Priority: high Component: PrivateTicketsPlugin
Severity: major Keywords:
Cc: vladimirr@…, rjollos Trac Release: 0.11

Description

If user has TICKET_VIEW_SELF permission and new ticket is created with that user's username as member of "CC" list, if usernames in "CC" are separated only by space and not by ",", that user is not able to access to the new ticket until CC list is fixed and usernames separated by coma.

Attachments (0)

Change History (3)

comment:1 Changed 5 years ago by rjollos

The AutocompleteUsersPlugin has kept me from ever encountering this situation since it appends a comma when autocompleting.

comment:2 Changed 4 years ago by rjollos

  • Cc rjollos added
  • Resolution set to worksforme
  • Status changed from new to closed

For some time now in Trac, CC lists are fixed up such that they are comma-separated. This is true in Trac 0.11.7, so if you find it is not a feature of an earlier version of Trac, I'd suggest upgrading.

comment:3 Changed 4 years ago by rjollos

It seems this is also true in Trac 0.10.6dev, from the test I just did. Please reopen if you can reproduce the issue under different circumstances.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.