Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6076 closed enhancement (fixed)

View Tickets report list is empty since trac-0.12 [8717]

Reported by: tjb@… Owned by: bobbysmith007
Priority: normal Component: TimingAndEstimationPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.12

Description

Since updating to trac-0.12 [8717], any trac projects which use the Timing and Estimation plugin have showed no reports when 'View Tickets' was selected.

This only occurs when the highest report number is from the Timing and Estimation reports.

A workaround is to create a new report numbered higher than the Timing and Estimation reports, then the whole list re-appears, including the TimingandEstimation report numbers, which are normally hidden.

This has worked with previous versions of trac-0.12

Attachments (0)

Change History (6)

comment:1 Changed 5 years ago by tjb@…

Logged on the main trac site as ticket 8785. The maintainers there suggested reporting here too, and passing back to them if they need to implement a change to 0.12

I realise the release I am working with is meant for trac 0.11, but it has worked well with 0.12 so far - I have logged this as an enhancement on that basis, to provide compatibility with 0.12

comment:2 Changed 5 years ago by bobbysmith007

I have reproduced this bug and am working on it. It seems that something in genshi changed which causes it to apply my filter on everything at once instead of on each node it matches sequentially.

I am currently hoping to rework this such that it can handle operating on all rows simultaneously instead of individually.

comment:3 Changed 5 years ago by bobbysmith007

  • Resolution set to fixed
  • Status changed from new to closed

(In [7011]) fixed #6076 - Changed the way I was filtering TandE report rows, so that it would work with newer genshis and newer tracs

comment:4 Changed 5 years ago by bobbysmith007

Please try this out and let me know if you experience any further trac12 / Genshi6 related problems.

Thanks very much for the good error report,

Russ

comment:5 Changed 5 years ago by tjb@…

I tried the latest - works perfectly, thanks for the prompt fix.

I will keep updated to your latest release every few days, and same for trac-0.12, and let you know if we have any problems.

I noticed a version bump when I installed, from 0.7.x to 0.8.x, but no visible changes. Anything I should know about?

Tony

comment:6 Changed 5 years ago by bobbysmith007

Nope, my versioning system is just increment by 1, when it gets to 10, I bump the next highest version number. Also I tend to try to keep the version numbers between the branches the same, since I try to keep them synced, however, sometimes there are more changes in one branch than another.

Most all changes to this plugin are at this point just bug fixes / maintenance.

Russ

Add Comment

Modify Ticket

Action
as closed The owner will remain bobbysmith007.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.