Modify

Opened 8 years ago

Closed 8 years ago

#614 closed defect (fixed)

clearsilver sortable_th macro has moved

Reported by: Matthias Kaschub Owned by: Blackhex
Priority: normal Component: DiscussionPlugin
Severity: major Keywords:
Cc: Trac Release: 0.10

Description

Stacktrace:

Traceback (most recent call last):
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 315, in dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 205, in dispatch
    req.display(template, content_type or 'text/html')
  File "/usr/lib/python2.4/site-packages/trac/web/api.py", line 329, in display
    data = self.hdf.render(template)
  File "/usr/lib/python2.4/site-packages/trac/web/clearsilver.py", line 288, in render
    template.parseFile(filename)
ParseError: ParseError: [/var/www/.python-eggs/TracDiscussion-0.5-py2.4.egg-tmp/tracdiscussion/templates/forum-list.cs:15] Undefined macro called: sortable_th(discussion.order, discussion.desc, 'id', 'ID', discussion.href + '?') 

I guess the Problem is, that the clearsilver macro sortable_th() has been moved from macros.cs to browser.cs: http://trac.edgewall.org/changeset/3147

Copying this macro into forum-list.cs seems to solve the problem for me.

Attachments (0)

Change History (3)

comment:1 Changed 8 years ago by mjk@…

same for topic-list.cs, admin-forum-list.cs and admin-group-list.cs

comment:2 Changed 8 years ago by Blackhex

  • Status changed from new to assigned

Possibly fixed in chageset 1131. Please test it on 0.10 as I couldn't.

comment:3 Changed 8 years ago by mjk@…

  • Resolution set to fixed
  • Status changed from assigned to closed

Yupp, works with 0.10 :-)

Thanks!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from Blackhex. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.