Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6158 closed defect (worksforme)

Error: 'PageAuthzPolicyEditor' object has no attribute 'get_htdocs_dirs'

Reported by: rjollos Owned by: robert_martin
Priority: normal Component: FineGrainedPageAuthzEditorPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

The FineGrainedPageAuthzEditorPlugin seems to be working okay, but there is an error that keeps popping up in my logs:

2009-11-04 12:34:39,691 Trac[main] ERROR: Internal Server Error:
Traceback (most recent call last):
File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
dispatcher.dispatch(req)
File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 205, in dispatch
resp = chosen_handler.process_request(req)
File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/chrome.py", line 379, in process_request
for dir in [os.path.normpath(dir[1]) for dir
AttributeError: 'PageAuthzPolicyEditor' object has no attribute 'get_htdocs_dirs' 

Any idea what is going on here?

Attachments (0)

Change History (7)

comment:1 Changed 5 years ago by rjollos

  • Summary changed from 'PageAuthzPolicyEditor' object has no attribute 'get_htdocs_dirs' to Error: 'PageAuthzPolicyEditor' object has no attribute 'get_htdocs_dirs'

comment:2 follow-up: Changed 5 years ago by robert_martin

This plugin isn't directly calling the code given in the bug report, it's using the AccountManager class from acct_mgr.api, and I think that is what is calling the code.

I can't see any similar messages in our log files. We're using Trac 0.11.5 and TracAccountManager 0.2.1dev. What versions are using and if they are different could you try with these version?

comment:3 in reply to: ↑ 2 Changed 5 years ago by rjollos

  • Resolution set to wontfix
  • Status changed from new to closed

Replying to robert_martin:

I can't see any similar messages in our log files. We're using Trac 0.11.5 and TracAccountManager 0.2.1dev. What versions are using and if they are different could you try with these version?

I'm on Trac 0.11.4 and an unknown version of AccoutManagerPlugin. Unfortunately, I can't upgrade, because my hosting provider controls this.

Since I don't have an associated behavior to report, and the solution isn't jumping out at your, I'm just going to close this for now.

comment:4 Changed 5 years ago by robert_martin

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:5 Changed 5 years ago by robert_martin

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please do not close my tickets. They are allocated to me and it is for me alone to close them, if and when appropriate with the correct resolution. wont fix means a refusal to fix, and is not the case, the nearest correct resolution is worksforme. Closing other peoples tickets means that they can not so easily check them. You can probably see the version of the AccoutManagerPlugin in the Admin page.

comment:6 Changed 5 years ago by mkc

It appears that the error is caused by the default chrome.py when it tries to call the get_htdocs_dir method on all registered ITemplateProvider objects.

Implementing a dummy method to satisfy the requirements of the interface cleared this error for us.

    def get_htdocs_dirs(self):
        return []

comment:7 Changed 5 years ago by robert_martin

Dummy method added. Thanks to mkc.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from robert_martin. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.