Modify

Opened 8 years ago

Closed 8 years ago

#616 closed defect (duplicate)

AttributeError:keys exception

Reported by: robert@… Owned by: athomas
Priority: normal Component: PollMacro
Severity: major Keywords:
Cc: Trac Release: 0.9

Description (last modified by coderanger)

Just checked out from SVN and built 0.9. I'm getting the following error:

  Error: Macro Poll(polling; yes; no) failed
  keys

... and here's the stacktrace from Trac log:


16:01:54 Trac[formatter] DEBUG: Executing Wiki macro Poll by provider <tracpoll.tracpoll.PollMacro object at 0x406c2bac>
16:01:54 Trac[formatter] ERROR: Macro Poll(polling; yes; no) failed
Traceback (most recent call last):
  File "/home/ckieffer/lib/python2.3/site-packages/trac/wiki/formatter.py", line 369, in _macro_formatter
    return macro.process(self.req, args, 1)
  File "/home/ckieffer/lib/python2.3/site-packages/trac/wiki/formatter.py", line 108, in process
    text = self.processor(req, text)
  File "/home/ckieffer/lib/python2.3/site-packages/trac/wiki/formatter.py", line 98, in _macro_processor
    return macro_provider.render_macro(req, self.name, text)
  File "build/bdist.linux-i686/egg/tracpoll/tracpoll.py", line 140, in render_macro
  File "build/bdist.linux-i686/egg/tracpoll/tracpoll.py", line 183, in render_poll
  File "build/bdist.linux-i686/egg/tracpoll/tracpoll.py", line 18, in __init__
  File "build/bdist.linux-i686/egg/tracpoll/tracpoll.py", line 29, in load
AttributeError: keys

Attachments (0)

Change History (2)

comment:1 Changed 8 years ago by coderanger

  • Description modified (diff)

Fixing formatting

comment:2 Changed 8 years ago by robert@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #594 (suggested fix posted over there)

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from athomas. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.