Modify

Opened 5 years ago

Last modified 14 months ago

#6219 new defect

On trac 0.12, TracWsgiPlugin always fails to load

Reported by: anonymous Owned by: martinpaljak
Priority: highest Component: TracWsgiPlugin
Severity: blocker Keywords:
Cc: Trac Release: 0.12

Description (last modified by rjollos)

Enabling the debug logging on trac we see:

2009-11-16 23:26:07,477 Trac[loader] DEBUG: Loading wsgiplugin.wsgiplugin from /usr/local/lib/python2.6/dist-packages/WSGITrac-0.3dev_r0-py2.6.egg
2009-11-16 23:26:07,480 Trac[loader] ERROR: Skipping "wsgiplugin.wsgiplugin = wsgiplugin.wsgiplugin": (can't import "ImportError: No module named request")

There doesn't seem to even be a reference to a 'request' import inside the plugin code, but it blocks there.

This was done on Ubuntu 9.10 server with python 2.6.4 and everything else working perfectly. Is there a dependency I am not aware of?

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by r,rossmair@…

  • Component changed from TracWysiwygPlugin to TracWsgiPlugin
  • Owner changed from jun66j5 to martinpaljak
  • Summary changed from On trac 0.12, TracWYSIWYG always fails to load to On trac 0.12, TracWsgiPlugin always fails to load

Wrong Plugin. Ticket description refers to TracWsgiPlugin. Title and component changed accordingly. (Note: I'm not the reporter.)

comment:2 Changed 14 months ago by rjollos

  • Description modified (diff)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.