Modify

Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#6240 closed defect (fixed)

track-hack post-commit hook failed - /var/trac/trachacks//log/trac-hacks-post-commit.log doesn't exist

Reported by: diroussel Owned by: otaku42
Priority: normal Component: TracHacks
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I just did a commit and got an error on the post commit hook:

Sending        0.11/LuntbuildTracIntegration/LuntbuildTracIntegrationPlugin.py
Transmitting file data .
Committed revision 7159.

Warning: post-commit hook failed (exit code 1) with output:
/var/svn/trachacks/hooks/post-commit: line 47: /var/trac/trachacks//log/trac-hacks-post-commit.log: No such file or directory

Attachments (0)

Change History (2)

comment:1 Changed 5 years ago by otaku42

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the hint, the issue is now fixed. It was caused due to me working on preparing the migration of trac-hacks.org from Trac 0.10 to 0.11, which involved moving some directories around.

comment:2 Changed 5 years ago by otaku42

Just came across another issue: we're now using virtualenvs, and the post-commit hook script was executed outside the correct virtualenv. This is now fixed, too.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from otaku42. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.