Modify

Opened 5 years ago

Closed 4 years ago

#6265 closed defect (duplicate)

Add Path with empty field leads to invalid configuration

Reported by: yves.kurz@… Owned by: kisg
Priority: normal Component: SvnAuthzAdminPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

If the Path input is empty and a user clicks the Add butten the plugin is adding the following line to to the configuration file:

[]

This line cannot be parsed by the plugin and leads to an error each time the trac is loaded.

Most recent call last:
File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 423, in _dispatch_request
File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 173, in dispatch
File "/usr/lib/python2.5/site-packages/trac/web/main.py", line 286, in _pre_process_request
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/api.py", line 79, in pre_process_request
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/api.py", line 142, in get_repository
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/svn_fs.py", line 286, in get_repository
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/svn_authz.py", line 47, in SubversionAuthorizer
File "/usr/lib/python2.5/site-packages/trac/versioncontrol/svn_authz.py", line 88, in __init__
File "/usr/lib/python2.5/ConfigParser.py", line 267, in read
File "/usr/lib/python2.5/ConfigParser.py", line 490, in _read

Attachments (0)

Change History (1)

comment:1 Changed 4 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5689.

Add Comment

Modify Ticket

Action
as closed The owner will remain kisg.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.