Modify

Opened 4 years ago

Closed 3 years ago

#6361 closed defect (duplicate)

Weakly-referenced object no longer exists

Reported by: anonymous Owned by: otaku42
Priority: normal Component: TracPastePlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by otaku42)

After I installed the plugin, the /pastebin url gives me the following error:

ReferenceError: weakly-referenced object no longer exists

Most recent call last:
File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 444, in _dispatch_request
File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 205, in dispatch
File "build/bdist.linux-x86_64/egg/tracpaste/web_ui.py", line 132, in process_request
File "build/bdist.linux-x86_64/egg/tracpaste/model.py", line 53, in get_pastes
File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 60, in execute
File "/usr/lib64/python2.4/site-packages/sqlite/main.py", line 233, in execute

Attachments (0)

Change History (3)

comment:1 Changed 4 years ago by otaku42

  • Description modified (diff)

What revision of the plugin are you using, and which version of Trac exactly?

comment:2 in reply to: ↑ description Changed 4 years ago by anonymous

Mi too!!

Most recent call last:

File "/home/booking/webapps/trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
  dispatcher.dispatch(req)
File "/home/booking/webapps/trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 205, in dispatch
  resp = chosen_handler.process_request(req)
File "/home/booking/lib/python2.4/TracPaste-0.2-py2.4.egg/tracpaste/web_ui.py", line 132, in process_request
  data = {
File "/home/booking/lib/python2.4/TracPaste-0.2-py2.4.egg/tracpaste/model.py", line 53, in get_pastes
  cursor.execute(sql, where_values)
File "/home/booking/webapps/trac/lib/python2.4/Trac-0.11.4-py2.4.egg/trac/db/util.py", line 51, in execute
  return self.cursor.execute(sql)
File "/usr/lib/python2.4/site-packages/sqlite/main.py", line 233, in execute
  if self.con.autocommit:

and

System Information:

  • User Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.7) Gecko/20100106 Ubuntu/9.10 (karmic) Firefox/3.5.7
  • Trac: 0.11.4
  • Python: 2.4.3 (#1, Sep 3 2009, 15:37:12) [GCC 4.1.2 20080704 (Red Hat 4.1.2-46)]
  • setuptools: 0.6c11
  • SQLite: 3.3.6
  • pysqlite: 1.1.7
  • Genshi: 0.5
  • Pygments: 1.2.2
  • Subversion: 1.5.5 (r34862)
  • jQuery: 1.2.6

Replying to anonymous:

After I installed the plugin, the /pastebin url gives me the following error:

ReferenceError: weakly-referenced object no longer exists

Most recent call last:
File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 444, in _dispatch_request
File "/usr/lib/python2.4/site-packages/trac/web/main.py", line 205, in dispatch
File "build/bdist.linux-x86_64/egg/tracpaste/web_ui.py", line 132, in process_request
File "build/bdist.linux-x86_64/egg/tracpaste/model.py", line 53, in get_pastes
File "/usr/lib/python2.4/site-packages/trac/db/util.py", line 60, in execute
File "/usr/lib64/python2.4/site-packages/sqlite/main.py", line 233, in execute

comment:3 Changed 3 years ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #6341, which has a patch.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from otaku42. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.