Modify

Opened 5 years ago

Closed 16 months ago

#6413 closed defect (fixed)

WYSIWYG plugin stops working when Agilo Advanced UI mode is enabled

Reported by: robert.taylor426@… Owned by: andreat
Priority: highest Component: AgiloForTracPlugin
Severity: normal Keywords: WYSIWYG Editor plugin
Cc: support@…, amr.noaman@…, jun66j5@… Trac Release: 0.11

Description

I have recently installed the Agilo for Scrum plugin. Everything seems fine except the WYSIWYG plugin has stopped working. When I try to edit a wiki page (with the WYSIWYG plugin enabled) it does not show the textarea/wysiwyg radio buttons, and instead shows an empty textarea artifact beneath the normal editing text area.

When I disable the Advanced UI in Admin->Agilo->General, this problem goes away, and the WYSIWYG plugin works fine again.

I suspect a css problem, but can not find a solution.

Attachments (0)

Change History (12)

comment:1 Changed 5 years ago by anonymous

  • Cc support@… added
  • Keywords WYSIWYG Editor plugin added

Hi there, I thought we fixed this problem, but apparently only in the ticket editing, can you confirm that in ticket editing works? It was a CSS + Javascript issue...

comment:2 follow-up: Changed 5 years ago by anonymous

Actually it seems the problem is there on both the ticket View->Add/Change and Edit->Comment text areas. Is this what you were referring to?

Trac 0.11.6
Agilo 0.8.4-r2257-20091218
Trac WYSIWYG 0.2

comment:3 in reply to: ↑ 2 Changed 5 years ago by anonymous

  • Priority changed from normal to low

Replying to anonymous:

Actually it seems the problem is there on both the ticket View->Add/Change and Edit->Comment text areas. Is this what you were referring to?

Trac 0.11.6
Agilo 0.8.4-r2257-20091218
Trac WYSIWYG 0.2

yes I fixed it in the past already by adding a JavaScript file to avoid the plugins to manipulate the styles and the DOM. We will have ti check again, bit that is not a priority ;-)

we can't guarantee compatibility with every other plugin ;-)

comment:4 Changed 5 years ago by anonymous

Understood. Thanks for your prompt replies and keep up the good work!

comment:5 Changed 5 years ago by anonymous

  • Cc amr.noaman@… added

comment:6 Changed 4 years ago by velappanv

Hi ,

Can you please provide the solution to fix this issue, Still I have been got up with this issue I am not able to use WYSIWYG plugin in my enviroment.

Thanks
vela

comment:7 Changed 4 years ago by anonymous

  • Priority changed from low to highest

comment:8 Changed 4 years ago by anonymous

Speaking for AgiloForScrumPlugin We do not have a high priority to fix this - we would love to get a patch for this though.

Regards,
Martin

comment:9 Changed 4 years ago by anonymous

I fixed this bug by removing the lines 16 to 21 from the file third_parties_hack.js
in the folder agilo/htdocs/js/ of the AgiloForScrumPlugin.
These lines where overriding the function TracWysiwyg.getTracPaths of the TracWysiwygPlugin which stops it working.

comment:10 Changed 4 years ago by anonymous

This is most strange, as these lines are there for exactly the purpose of making trac wysiwyg work. Could anybody tell me what this method is supposed to return?

What we do return is the BASE_UR, i.e. the difference between trac running in multi-env mode or not.

Regards,
Martin

comment:11 Changed 4 years ago by jun66j5

  • Cc jun66j5@… added

Hi,

I fixed the issue in r8147 and tested with Agilo 1.2.1.
Try to use r8147 or later, if you can.

comment:12 Changed 16 months ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.