Modify

Opened 4 years ago

Closed 4 years ago

#6495 closed defect (fixed)

KeyError: 'fields'

Reported by: turkanis Owned by: coderanger
Priority: normal Component: MasterTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

This appears to be essentially the same problem as #3344.

When I attempt to view a ticket description diff, I get:

Trac detected an internal error:
KeyError: 'fields'

Python Traceback
Most recent call last:
 File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 435, in _dispatch_request
  dispatcher.dispatch(req)
 File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 216, in dispatch
  template, data, content_type = \
 File "/usr/lib/python2.4/site-packages/Trac-0.11.4-py2.4.egg/trac/web/main.py", line 311, in _post_process_request
  resp = f.post_process_request(req, *resp)
 File "build/bdist.linux-i686/egg/mastertickets/web_ui.py", line 64, in post_process_request

The attached patch fixes the problem. I have borrowed the inserted text from [3988].

Attachments (1)

masterticketsplugin-6495.patch (729 bytes) - added by turkanis 4 years ago.

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by turkanis

comment:1 follow-up: Changed 4 years ago by turkanis

This appears to be a duplicate of #3920, but the patch is different

comment:2 in reply to: ↑ 1 Changed 4 years ago by turkanis

Replying to turkanis:

This appears to be a duplicate of #3920, but the patch is different

And #5503

comment:3 Changed 4 years ago by boonekamp

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from coderanger. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.