Modify

Opened 5 years ago

Closed 2 years ago

#6727 closed defect (invalid)

How to uninstall the plugin?

Reported by: dan@… Owned by: viola
Priority: normal Component: CodeReviewPlugin
Severity: normal Keywords: uninstall remove
Cc: Rockcaster Trac Release: 0.11

Description

Hello - I'm trying to find out how to remove CodeReviewPlugin. I installed it using this command:

easy_install -U -Z http://trac-hacks.org/wiki/CodeReviewPlugin

Once installed, the client that asked for this changed their mind and has asked me to back the changes out, however I am unable to do so using the easy_install command. I've tried to issue the following commands, with no success:

easy_install -m codereviewplugin easy_install -m CodeReviewPlugin easy_install -m http://trac-hacks.org/wiki/CodeReviewPlugin

I'm fairly new to python (though I am versed in perl) and I'm unfamiliar with the package management system. If someone would be so kind as to let me know how to remove CodeReviewPlugin that would be most excellent.

Thanks in advance!

-Dan

Attachments (0)

Change History (16)

comment:1 Changed 5 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

Hello,

You just need to locate the egg for the plugin and manually delete it. You'll also want to remove related entries from TracIni.

You should also be able to simply disable the plugin from the WebAdmin page.

Please reopen if you are still having issues and we can discuss.

comment:2 Changed 5 years ago by rjollos

  • Summary changed from Client thought they wanted CodeReviewPlugin, changed their minds to How to uninstall the plugin?

comment:3 Changed 5 years ago by dan@…

The problem is that I cannot find an .egg file, nor can I see any code or files that contain 'codereview' anywhere - however the functionality on the file browser is still there. The developers are complaining that they do not have the 'down arrow' that drills down into the filestructure anymore - and that vanished after installing this plugin.

comment:4 Changed 5 years ago by rjollos

Did you look at whether you can disable it from the WebAdmin panel?

comment:5 Changed 5 years ago by dan@…

Interestingly enough I don't even see it listed.

comment:6 Changed 5 years ago by rjollos

How about going into the [components] section of trac.ini and removing anything that starts with codereview. ?

comment:7 follow-ups: Changed 5 years ago by dan@…

no files within the trac project directory match : grep -Ri codereview .

What I'm really curious about is how it could change the look of the code/file viewer but otherwise be completely 'invisible'

comment:8 in reply to: ↑ 7 ; follow-up: Changed 5 years ago by rjollos

Replying to dan@atenlabs.com:

no files within the trac project directory match : grep -Ri codereview .

Would you be willing to send me a copy of your trac.ini file? You might want to make sure any passwords for e.g. your mailserver are removed before sending it. I wouldn't recommend posting it to this ticket, which is why I'm suggesting emailing it to me.

ryano @t physiosonics dot com

comment:9 in reply to: ↑ 7 Changed 5 years ago by rjollos

Replying to dan@atenlabs.com:

What I'm really curious about is how it could change the look of the code/file viewer but otherwise be completely 'invisible'

Yeah, it definitely shouldn't, and I can't imaging that being the case unless the developer did something very wrong.

comment:10 follow-up: Changed 5 years ago by anonymous

I'm versed enough to be able to tell you with absolute certainty that the string you're looking for is nowhere in the ini.

I can't post or send the ini file because this is an in-production trac for a client.

My involvement with this trac install has been: 1) Help client migrate from old server to new server (wherein I simply rsync'ed the files, and copied the postgres db) 2) Installed 2 plugins - customfieldadminplugin and codereviewplugin

Shortly thereafter one of the employees complained that the svn tree browser was 'different' and mentioned the little dropdown arrows were gone.

I figured out of the only two plugins that were installed, the codereview plugin was responsible. I didn't get any errors upon the installation, but after the install of the plugin there are noticeable differences with the svn browser but I cannot for the life of me find what is responsible for them.

comment:11 in reply to: ↑ 10 Changed 5 years ago by rjollos

  • Resolution fixed deleted
  • Status changed from closed to reopened

Replying to anonymous:

I'm versed enough to be able to tell you with absolute certainty that the string you're looking for is nowhere in the ini.

Okay, cool. With most bug reports, people are making really basic mistake, so I've learned to assume to check really basic stuff and not make any assumptions about user experience.

If I was you, I would setup a Trac development environment instance, install the CodeReviewPlugin, and try to reproduce the damage it causes. Have you setup a Trac dev environment before? Its fairly straightforward.

comment:12 Changed 5 years ago by dan@…

I'm fairly new to trac - This is my second interaction with it. I had another client that wanted other things done using trac, which I also had to learn by sort of, 'trial by fire'.

I suppose thats the last thing left to try - stand up a new project, drop in the plugin, and see if it behaves the same.

Thanks for the help!

comment:13 Changed 5 years ago by rjollos

I tried installing under Trac0.12dev. You are right, no entries in the WebAdmin panel and nothing in trac.ini. The difference is that I don't see any CodeReviewPlugin functionality at all.

(test)rjollos@ubuntu:~/Workspace/test$ easy_install http://trac-hacks.org/svn/codereviewplugin
Downloading http://trac-hacks.org/svn/codereviewplugin
Doing subversion checkout from http://trac-hacks.org/svn/codereviewplugin to /tmp/easy_install-YP8CbW/codereviewplugin
Processing codereviewplugin
Running 0.11/setup.py -q bdist_egg --dist-dir /tmp/easy_install-YP8CbW/codereviewplugin/0.11/egg-dist-tmp-HJon0H
zip_safe flag not set; analyzing archive contents...
Adding CodeReview 0.1 to easy-install.pth file

Installed /home/rjollos/Workspace/test/lib/python2.6/site-packages/CodeReview-0.1-py2.6.egg
Processing dependencies for CodeReview==0.1
Finished processing dependencies for CodeReview==0.1

As far as I know, a plugin is just an egg. The egg must be loaded when you start Trac.

If I set the log level to DEBUG, log to the console, restart Trac and refresh the WebAdmin page, I get this:

(test)rjollos@ubuntu:~/Workspace/test$ tracd -r --port 8000 tracdev
Server starting in PID 20381.
Serving on 0.0.0.0:8000 view at http://127.0.0.1:8000/
Using HTTP/1.1 protocol version
11:26:57 PM Trac[env] INFO: -------------------------------- environment startup [Trac 0.12dev-r9228] --------------------------------
11:26:57 PM Trac[loader] DEBUG: Adding plugin TracDeveloper 0.2 from /home/rjollos/Workspace/test/tracdev/plugins/TracDeveloper-0.2-py2.6.egg
11:26:57 PM Trac[loader] DEBUG: Loading codereview from /home/rjollos/Workspace/test/lib/python2.6/site-packages/CodeReview-0.1-py2.6.egg
11:26:57 PM Trac[loader] ERROR: Skipping "codereview = codereview": (can't import "ImportError: No module named db_default")

So maybe you can see if the egg is loading and if so, where is loading from.

comment:14 Changed 5 years ago by rjollos

The more I think about it, I think that you must be able to see the plugin loading from somewhere if you have the log level to DEBUG and can view the log. If not, your server might be possessed.

comment:15 in reply to: ↑ 8 Changed 5 years ago by dnedelchev

Replying to rjollos:

Replying to dan@atenlabs.com:

no files within the trac project directory match : grep -Ri codereview .

Note, Dan wrote he installed the plugin using -Z (--always_unzip) option.

I'm new to Trac too, so please excuse me if I'm wrong in any detail, but as far as I know, plugin's eggs are usually installed not in the project's location (i.e. one doesn't have to look in the trac environment).

When I have a plugin installed as an egg file, I see it installed plugin as an .egg file located in my python installation's "Lib/site-packages" directory.

Then I see the decompressed .egg content in the trac environmennt's .egg directory. However, is I try to delete that content from the environment, it reappears there since (as I understand) it's nothing else but a cache.

But when I have a plugin installed with -Z option ("/usr/bin/easy_install -Z ..."), I see it installed plugin as an .egg directory located in my python installation's "Lib/site-packages" directory.
In this case I don't see an instance of the plugin in the trac environment's directory. It should be because the .egg is already decompressed during installation so there should be no need of caching its content.

comment:16 Changed 2 years ago by rjollos

  • Resolution set to invalid
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed The owner will remain viola.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.