Modify

Opened 4 years ago

Closed 4 years ago

#6728 closed enhancement (fixed)

graphviz 2.26.0 and higher, layout engine detection fix (linux)

Reported by: makadev Owned by: makadev
Priority: low Component: ProjectPlanPlugin
Severity: critical Keywords: graphviz, compatibility
Cc: Trac Release: 0.11

Description

Fixup for graphviz 2.26.0+ Layout Engine Detection, see http://trac-hacks.org/wiki/ProjectPlanPlugin/DotCompatibility

I dont know wether this is a derivate 1/graphviz Problem 2.
From graphviz dot Manpage: "-Klayout override the default layout engine implied by the command name.". This does not work in projectplanplugin/0.11/trunk/projectplan/dotrender.py@7634#L103 (may caused by non-shell execution), neither the implication nor the -K option.
After some Tests it seems, the -K is explicit hard-coded: "dot dot ..." instead of "dot -Kdot ..." works and "dot ..." returns the same Error as "dot -K ...".

For now a (temporary/selectable) workaround would be nice.

  1. Tree Stamp: Wed, 24 Feb 2010 07:00:01 +0000
  2. couldn't find neither bug reports for 2.6 nor 2.26 (http://www.graphviz.org/bugs/buglist.html)

Attachments (0)

Change History (2)

comment:1 Changed 4 years ago by makadev

  • Status changed from new to assigned

comment:2 Changed 4 years ago by makadev

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7722]) dot 2.26.0+ K cmdline fix selectable in admin panel, improved error log link, closes #6728

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from makadev. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.