Modify

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#6883 closed enhancement (duplicate)

Email to discussion

Reported by: geeksrik@… Owned by: Blackhex
Priority: high Component: DiscussionPlugin
Severity: major Keywords:
Cc: geeksrik@… Trac Release: 0.11

Description

Hi

Is it possible to create an entirely new discussion topic by just emailing to an ID whose mails are parsed by this plugin and put into the respective discussion depending on subject.

Also for an existing discussion comment notification is it possible to reply to that notification so that the reply is placed as the next comment on that discussion page. I do agree that some IMAP or POP mailbox maybe required for this purpose which is polled frequenty by linux/windows (this can be schedulable) but the more important part is parsing of these emails.

Only paid tools offer this feature and i see that only this feature is a differentiator from TRAC. If this feature is offered by your plugin, it will serve both as by-email discussion participation and on-forum discussion participation.

Attachments (0)

Change History (19)

comment:1 Changed 5 years ago by anonymous

  • Type changed from defect to enhancement

comment:2 Changed 5 years ago by anonymous

  • Cc geeksrik@… added

comment:3 Changed 5 years ago by anonymous

  • Priority changed from normal to high
  • Severity changed from normal to major

comment:4 Changed 5 years ago by Blackhex

  • Status changed from new to assigned

Do you mean EmailtoTracScript? I think it could be extended to support discussions.

comment:5 Changed 5 years ago by anonymous

yes. very much. but I found that a bit inconvenient to use with tickets. With changes form your side, it will gel nicely well with discussionplugin itself. Whichever way you look at it, is what TRAC misses today is that if i get a notification, i cannot comment on it to get my comment onto the page where the discussion is going on.

any help in this regard will be greatly appreciated

comment:6 Changed 5 years ago by anonymous

Currently, I'm pretty occupied but I'll try to take a look at it soon.

comment:7 Changed 5 years ago by geeksrik@…

Blackhex, did you get any opportunity to look further into this please?

comment:8 Changed 5 years ago by geeksrik@…

Whats required is a script that will parse a mailbox and update the trac.db. The mailbox could support POP3 protocol for a start.

comment:9 Changed 5 years ago by Blackhex

Nope, sorry. And I'll be away for next three weeks, I'll take a look on that when I return.

comment:10 Changed 4 years ago by Blackhex

  • Resolution set to duplicate
  • Status changed from assigned to closed

Solution to this will be completely done in email2trac script so this is a duplicate of https://subtrac.sara.nl/oss/email2trac/ticket/197. I'm currently working on it.

comment:11 Changed 4 years ago by geeksrik@…

Thank you very much. I appreciate your effort a lot. It means so much to my current need for using trac + discussion plugin.

comment:12 Changed 4 years ago by Blackhex

I've done it. The patch against email2trac trunk is linked to the ticket. Could you please test it and send me any comments what you would like to change or add. Thank you.

comment:13 Changed 4 years ago by geeksrik@…

Blackhex, thanks very much, i will test and give you inputs on how it works!

comment:14 Changed 4 years ago by geeksrik@…

Hi Blackhex, do you think you can zip and send me the file? i am unable to access that website due to proxy restrictions.

comment:15 Changed 4 years ago by geeksrik@…

is this correct ?

[root@astrotrac email2trac-1.3.2]# patch < discussion_plugin_support-1.diff
(Stripping trailing CRs from patch.)
patching file email2trac.py.in
Hunk #3 succeeded at 300 (offset -5 lines).
Hunk #5 succeeded at 1065 (offset -65 lines).
Hunk #7 succeeded at 1137 with fuzz 2 (offset -65 lines).
Hunk #8 FAIL at 1368.
Hunk #9 FAIL at 1475.
Hunk #10 succeeded at 1843 (offset -8 lines).
Hunk #11 succeeded at 1798 (offset -65 lines).
Hunk #12 succeeded at 1881 (offset -8 lines).
Hunk #13 succeeded at 1942 (offset -65 lines).
Hunk #14 succeeded at 2100 (offset -8 lines).
2 out of 14 hunks FAIL -- saving rejects to file email2trac.py.in.rej

comment:16 Changed 4 years ago by geeksrik@…

Also, could you please let me know in a simple way how I can install this? I have followed instructions for email2trac installation, and i did the build with my trac username, mta name as default, and after applying your patch. with this, the binaries were generated in my /usr/local/bin.

the question is what next? I have to put the email2trac.conf in the same folder as trac.ini ? and put in my mail server values? is this alone enough for discussion plugin to pick it up? and does discussion plugin run a cron job to pick up mails off a mailbox? or does it route them to this newly generated binary instead? I am a bit confused, can you clarify please?

thanks in advance
srikanth

comment:17 Changed 4 years ago by geeksrik@…

I did a bit of playing around. firstly I would like to explain my need more in specific:

I have a mailbox which accepts emails. Lets say this is "mybox@…", now i want trac discussion plugin to be able to send mails (notificiations) to trac users, and the reply id must be "mybox@…". Assuming someone replies to a discussion, this mail will be left in "mybox@…". A cron job which is running then needs to read this mailbox, route that email to discussion plugin which will put the content at its appropriate place.

Now having said this, I am trying to understand what email2trac does. Firstly I believe this plugin does not scan mailboxes like "mybox@…" (pop or imap). secondly does your diff (patch) actually do this scanning of mailbox? what is the exact cron job i need to run in order that above process happens every minute or two? currently, i am only still getting notifications from DP, but any replies after setting above reply to address does not get picked up by DP.

The email2trac plugin itself has limited documentation without examples and its getting increasingly difficult to understand how it works.

Any help in detailing this a bit will be much appreciated.
thanks!

comment:18 Changed 4 years ago by Blackhex

OK, so you've managed to apply the patch. Now for the configuration: I agree that email2trac's documentation is not really detailed for new users that don't know much about e-mail server configuration which I'm too. I haven't setup this because it wasn't necessary for development so I have no experience how to do it exactly. I can give you just my thoughts. I thinks that there are two ways how to get email2trac working in your case: if you have your "mybox@…" e-mail server on the same machine as the Trac, you can edit /etc/mail/aliases file depending on e-mail server software you use and according to this page https://subtrac.sara.nl/oss/email2trac/wiki/Email2tracMta . In the case you have your e-mail server on different machine, I think it's possible to write/use a simple script launched as a cron job that downloads e-mails from the mailbox to some folder and then it runs:

for file in *.mbox;
do
  /usr/bin/email2trac --project "Test" < $file
done;

I don't think you should move email2trac.conf after installation.

comment:19 Changed 4 years ago by Blackhex

I just want to note that e-mail subject to start a new topic should be for example:

Forum #4 - This is an e-mail submitted topic

while replies to topics and their messages are regular replies to e-mail notification, so:

Re: [Project] Topic #3 - Subject of the topic

or

Re: [Project] Message #15 - Subject of the topic

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.