Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#6993 closed defect (fixed)

Form Submission returns 'RuntimeError: No Content-Length header set'

Reported by: andrewbates Owned by: andrewbates
Priority: normal Component: TracFormsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

How to Reproduce

While doing a POST operation on /formdata/update, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'c84efd0f761efab57bb9b69c',
 '__backpath__': u'/projects/andyland/wiki/ShoppingLists',
 '__basever__': u'1271359721',
 '__context__': u'/wiki/ShoppingLists',
 '__track_fields__': u'yes',
 'dishwasher_detergent': u'on',
 'toothpaste': u'on',
 'trashbags_kitchen': u'on',
 'ziplockbags_gallon': u'on'}

User Agent was: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.3) Gecko/20100413 Gentoo Firefox/3.6.3

System Information

Trac 0.12dev-r9405
CustomFieldAdmin 0.2.2
Docutils 0.6
Genshi 0.6dev-r1096
mod_wsgi 3.1 (WSGIProcessGroup trac WSGIApplicationGroup %{GLOBAL})
Pygments 1.3.1
pysqlite 2.6.0
Python 2.6.2 (r262:71600, Nov 19 2009, 09:21:43)
[GCC 4.3.4]
RPC 1.0.6
setuptools 0.6
SQLite 3.6.22
Subversion 1.6.9 (r901367)
jQuery 1.4.2

Enabled Plugins

BatchModify 0.4.1
graphviz 0.7.6dev
NavAdd 0.1
PDFRedirector 0.1
timingandestimationplugin 0.9.0b
TracAccountManager 0.2.1dev-r7737
TracBzr 0.3.2-dev-20100401
TracCustomFieldAdmin 0.2.2
TracDateField 1.0.1
TracForms 0.3
TracMasterTickets 2.1.3
TracPrivateTickets 2.0.2
TracWysiwyg 0.2-r7772
TracXMLRPC 1.0.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib64/python2.6/site-packages/Trac-0.12dev_r9405-py2.6.egg/trac/web/main.py", line 514, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib64/python2.6/site-packages/Trac-0.12dev_r9405-py2.6.egg/trac/web/main.py", line 235, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib64/python2.6/site-packages/TracForms-0.3-py2.6.egg/tracforms/formdata.py", line 55, in process_request
    req.write(str(e))
  File "/usr/lib64/python2.6/site-packages/Trac-0.12dev_r9405-py2.6.egg/trac/web/api.py", line 528, in write
    raise RuntimeError("No Content-Length header set")
RuntimeError: No Content-Length header set

Attachments (1)

content-length.patch (1.3 KB) - added by andrewbates 4 years ago.
adds appropriate 'Content-Length' headers to request responses

Download all attachments as: .zip

Change History (5)

comment:1 Changed 4 years ago by andrewbates

  • Status changed from new to assigned

Changed 4 years ago by andrewbates

adds appropriate 'Content-Length' headers to request responses

comment:2 Changed 4 years ago by andrewbates

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:3 Changed 3 years ago by hasienda

(In [10141]) TracFormsPlugin: Rework changeset [9580], refs #6993.

Due to improper ticket handling the aforementioned report and suggested fix
was gone largely unnoticed. Current code now resembles a slightly modified
version of the patch. Thanks to andrewbates for the original contribution.

comment:4 Changed 3 years ago by hasienda

(In [10143]) TracFormsPlugin: Releasing version 0.3, pushing development to 0.4, closes #3445, #3550, #3741, #4759 and #8258, refs #3388 and #6993.

This is a major release requiring a Trac environment upgrade.

While the parser logic remains unchanged, there is a lot new supplementary
funcionality to make TracForms behave more like the existing Trac core
resources (ticket, wiki, attachment, ...).

This version performs a series of non-trivial db schema changes, that
especially may leave traces of stale forms (i.e. recorded for wiki pages,
that don't exist anymore). So please make sure to read the changelog,
BACKUP your environment(s) before installing this version as usual and check
the new db tables forms, forms_fields and forms_history after upgrading.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from andrewbates. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.