Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#6997 closed defect (invalid)

Use true/false for Billing and Internal flags

Reported by: micahknox@… Owned by: bobbysmith007
Priority: high Component: TimeVisualizerPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

I am using the Mylyn plug-in for Eclipse to interface with Trac and although it does recognize the ticket fields added by the Timing and Estimation Plug-in, the do no work because Mylyn treats them as a Boolean using true/false values but they were coded to work off a yes/no value. Can this be changed so they work using true/false on the back end but report as yes/no visually?

Attachments (1)

Screen shot 2010-04-16 at 8.29.21 AM.png (36.2 KB) - added by micahknox@… 4 years ago.
Screen shot from Trac

Download all attachments as: .zip

Change History (3)

Changed 4 years ago by micahknox@…

Screen shot from Trac

comment:1 Changed 4 years ago by bobbysmith007

  • Resolution set to invalid
  • Status changed from new to closed

I think they are actually 0 and 1 in the database. This is all part of trac:TracTicketsCustomFields and therefore not something that this plugin has control over. The 0 and 1 are turned into yes and no along the way for display.

I will look into this to see what can be done, however, it really seems like a bug in Mylyn/trac interaction, not a bug in this plugin. If I come up with something I will reopen this ticket (Feel free to do the same if you have any suggestions).

Russ

comment:2 Changed 4 years ago by bobbysmith007

  • Component changed from TimingAndEstimationPlugin to TimeVisualizerPlugin

I dont use eclipse or mylyn but googling lead me to these:

A forum thread about this TimingAndEstimation Integration:

Using Trac XML-RPC might allow you to bypass some of the problems you are experiencing.

HTH,

Russ

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from bobbysmith007. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.