Modify

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#7008 closed defect (fixed)

column "parent" does not exis

Reported by: anonymous Owned by: walnut
Priority: normal Component: ChildTicketsPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description

Hello!

I'm using Trac 0.11.6 and after i enables the childTickets plugin, I got the following error message whenever i click to an existing ticket, but this is the case when i click to the "Create ticket" button:

Trac detected an internal error:
ProgrammingError: column "parent" does not exist LINE 1: SELECT ticket,value FROM ticket_custom WHERE name="parent" ^

In New Ticket form, i can see the Parent ID column

Attachments (1)

postgres_patch.diff (710 bytes) - added by davidkovaccs@… 4 years ago.
patch for postgresql

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by davidkovaccs@…

patch for postgresql

comment:1 Changed 4 years ago by anonymous

The problem was caused by the postgresql query parser, i've attached the patch for it

comment:2 Changed 4 years ago by walnut

  • Status changed from new to assigned

comment:3 Changed 4 years ago by walnut

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [7877])
Updated version info in setup.py for fix #7008.

comment:4 Changed 4 years ago by walnut

Thx to davidkovaccs@… for patch!

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from walnut. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.