Modify

Opened 4 years ago

Closed 23 months ago

#7020 closed defect (duplicate)

[Patch] Install leads to Error line 79

Reported by: fducros@… Owned by: XayOn
Priority: high Component: TicketBackLinksMacro
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

fred@svn:/var/tmp/ticketbacklinksmacro/0.11$ sudo python setup.py 
install
running install
running bdist_egg
running egg_info
writing TicketBackLinksDescription.egg-info/PKG-INFO
writing top-level names to TicketBackLinksDescription.egg-info/top_level.txt
writing dependency_links to TicketBackLinksDescription.egg-info/dependency_links.txt
writing entry points to TicketBackLinksDescription.egg-info/entry_points.txt
reading manifest file 'TicketBackLinksDescription.egg-info/SOURCES.txt'
writing manifest file 'TicketBackLinksDescription.egg-info/SOURCES.txt'
installing library code to build/bdist.linux-i686/egg
running install_lib
running build_py
creating build/bdist.linux-i686/egg
creating build/bdist.linux-i686/egg/TicketBackLinksDescription
copying build/lib/TicketBackLinksDescription/macro.py -> build/bdist.linux-i686/egg/TicketBackLinksDescription
copying build/lib/TicketBackLinksDescription/__init__.py -> build/bdist.linux-i686/egg/TicketBackLinksDescription
byte-compiling build/bdist.linux-i686/egg/TicketBackLinksDescription/macro.py to macro.pyc
  File "build/bdist.linux-i686/egg/TicketBackLinksDescription/macro.py", line 79
    return buf.getvalue()
SyntaxError: 'return' outside function

byte-compiling build/bdist.linux-i686/egg/TicketBackLinksDescription/__init__.py to __init__.pyc
creating build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/PKG-INFO -> build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/SOURCES.txt -> build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/dependency_links.txt -> build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/entry_points.txt -> build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/not-zip-safe -> build/bdist.linux-i686/egg/EGG-INFO
copying TicketBackLinksDescription.egg-info/top_level.txt -> build/bdist.linux-i686/egg/EGG-INFO
creating 'dist/TicketBackLinksDescription-0.1-py2.5.egg' and adding 'build/bdist.linux-i686/egg' to it
removing 'build/bdist.linux-i686/egg' (and everything under it)
Processing TicketBackLinksDescription-0.1-py2.5.egg
removing '/usr/lib/python2.5/site-packages/TicketBackLinksDescription-0.1-py2.5.egg' (and everything under it)
creating /usr/lib/python2.5/site-packages/TicketBackLinksDescription-0.1-py2.5.egg
Extracting TicketBackLinksDescription-0.1-py2.5.egg to /usr/lib/python2.5/site-packages
  File "/usr/lib/python2.5/site-packages/TicketBackLinksDescription-0.1-py2.5.egg/TicketBackLinksDescription/macro.py", line 79
    return buf.getvalue()
SyntaxError: 'return' outside function

TicketBackLinksDescription 0.1 is already the active version in easy-install.pth

Installed /usr/lib/python2.5/site-packages/TicketBackLinksDescription-0.1-py2.5.egg
Processing dependencies for TicketBackLinksDescription==0.1
Finished processing dependencies for TicketBackLinksDescription==0.1

Attachments (1)

macro.py (3.6 KB) - added by farialima 4 years ago.
proposed fix. Please test !

Download all attachments as: .zip

Change History (7)

Changed 4 years ago by farialima

proposed fix. Please test !

comment:1 Changed 4 years ago by rjollos

  • Description modified (diff)
  • Owner changed from mchua to rjollos

Reassigning to new maintainer.

comment:2 Changed 4 years ago by rjollos

  • Priority changed from normal to high
  • Summary changed from Install leads to Error line 79 to [Patch] Install leads to Error line 79

This should be a fairly easy fix, so I'm bumping up the priority.

comment:3 Changed 4 years ago by rjollos

  • Component changed from TracBacksPlugin to TicketBackLinksMacro
  • Owner changed from rjollos to XayOn

This was incorrectly assigned. Its a report against the TicketBackLinksMacro.

comment:4 follow-up: Changed 3 years ago by lucasrangit

Tested the patch from #7832 with Trac 0.11.5 on Ubuntu 9.10 and it allowed me to install it. It is a duplicate of this ticket but this ticket does not contain a patch so I used the one there.

I will test the functionality next and apply the SQL changes mentioned in the other tickets if necessary.

comment:5 in reply to: ↑ 4 Changed 3 years ago by lucasrangit

Replying to lucasrangit:

I will test the functionality next and apply the SQL changes mentioned in the other tickets if necessary.

I had the issue that tickets would not get seen when a ticket number did not have a trailing white-space character. The correct SQL query is described at #6382. I use SQLite 2.8.17 by the way.

comment:6 Changed 23 months ago by rjollos

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #7832 since #7832 included a proper patch in unified diff format.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from XayOn. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.