Modify

Opened 4 years ago

Closed 2 years ago

#7028 closed defect (fixed)

System-wide installation doesn't work

Reported by: john@… Owned by: rjollos
Priority: high Component: TracWikiToPdfPlugin
Severity: normal Keywords:
Cc: Trac Release: 0.11

Description (last modified by rjollos)

I:

  1. Checked out the latest code from Subversion
  2. Made an egg
  3. Copied it into the system's site-packages directory
  4. Added "wikitopdf.* = enabled" in the [components] section of a projects trac.ini

However, the plugin has not become enabled, and doesn't show in the Admin->Plugins page.

If I copy the egg into the project's 'plugins' directory, it works.

In the failure case there is nothing relevant in the trac.log file.

If I copy the egg file into the project's plugins directory, the trac.log file shows the plugin being loaded from the _system_ directory:

2010-04-26 14:59:33,832 Trac[loader] DEBUG: Loading wikitopdf.web_ui from /usr/lib/python2.4/site-packages/TracWikiToPdfPlugin-2.3.1-py2.4.egg

What's going on!?

Attachments (0)

Change History (9)

comment:1 Changed 4 years ago by nhruby

This appears to be caused by the lack of an __init__.py file in the wikitopdf module. You can maually add an empty one in the source directory and then reissue the build and install steps and it should work.

comment:2 Changed 4 years ago by rjollos

  • Owner changed from diorgenes to rjollos
  • Priority changed from normal to high
  • Status changed from new to assigned

comment:3 Changed 4 years ago by rjollos

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [9779]) Added __init__.py file to fix install failure. Removed requirement for htmldoc from setup.py since an install failed even when the package was installed system-wide. Fixes #7028.

comment:4 Changed 4 years ago by rjollos

  • Description modified (diff)

comment:5 Changed 4 years ago by rjollos

(In [9780]) Applied fix from [9779] to 0.10 branch. Renamed context conversion link from WikiToPdf -> PDF. Refs #7028.

comment:6 Changed 4 years ago by jberanek

  • Resolution fixed deleted
  • Status changed from closed to reopened

Hmm, doesn't seem to fix it for me. I generated an __init__.py within wikitopdf, remade the egg, and I still get the same behaviour...

comment:7 Changed 4 years ago by rjollos

Try deleting the file /usr/lib/python2.4/site-packages/TracWikiToPdfPlugin-2.3.1-py2.4.egg and see if it then loads the egg from the TRACENV directory.

comment:8 Changed 4 years ago by rjollos

Okay, sorry, I misundestood your issue, so my last comment won't make any sense. Let me test out the system-wide installation. I always do an installation to the TRACENV directory.

comment:9 Changed 2 years ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

Try: python setup.py install, and I think it will work for you. Please reopen if you continue to have issues. You may also want to read t:TracPlugins, for the different installation options. I think this is purely an install issue at this point.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from rjollos. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.