Modify

Opened 4 years ago

Closed 4 years ago

Last modified 11 months ago

#7038 closed defect (fixed)

[Patch] Add Trac 0.12 compatible version

Reported by: anonymous Owned by: echo0101
Priority: normal Component: TracTicketStatsPlugin
Severity: major Keywords:
Cc: Trac Release: 0.12

Description

I tried setting this up in our development environment but ran into some issues. To run this plugin on MySQL I first needed to make the changes mentioned in http://trac-hacks.org/ticket/5568

I then had more problems that I think are due to 0.12 changes. First with

RuntimeError: No Content-Length header set

so I changed

req.write(jsdstr)

to

req.send(jsdstr.encode('utf-8'))

Stats were now returned but they were all 0. I noticed the sql generated looked for dates in seconds while the table used microseconds. I changed all the

to_timestamp


to

to_utimestamp

That was enough to get it working.

http://www.moxy.com.au/

Attachments (0)

Change History (6)

comment:1 in reply to: ↑ description Changed 4 years ago by anonymous

Replying to anonymous:

Stats were now returned but they were all 0. I noticed the sql generated looked for dates in seconds while the table used microseconds. I changed all the

to_timestamp


to

to_utimestamp

That was enough to get it working.

http://www.moxy.com.au/

I can confirm this.

comment:2 Changed 4 years ago by rjollos

Partial duplicate of #6333, but I'll close the other tickets since this also has a fix for the 0.12 timestamp format.

comment:3 Changed 4 years ago by rjollos

  • Summary changed from Tickets not being shown in chart to [Patch] Add Trac 0.12 compatible version

comment:4 Changed 4 years ago by rjollos

(In [8413]) Creating a 0.12 branch. Refs #7038.

comment:5 Changed 4 years ago by rjollos

  • Resolution set to fixed
  • Status changed from new to closed

(In [8414]) Changed timestamp format for Trac 0.12. Fixes #7038.

comment:6 Changed 11 months ago by rjollos

(In [13103]) Refs #7038: Follow-on to [8414]. Made trunk compatible with Trac 0.11 and higher by importing to_utimestamp only when the function exists, and falling back to to_timestamp.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from echo0101. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.