Modify

Opened 4 years ago

Closed 4 years ago

Last modified 3 years ago

#7096 closed defect (fixed)

Error loading plugin

Reported by: maciej@… Owned by: kisg
Priority: high Component: SvnAuthzAdminPlugin
Severity: major Keywords:
Cc: Trac Release: 0.11

Description

I'm trying to install SvnAuthzAdminPlugin, but after installing using easy_install plugin isn't available on plugins list in admin panel.

I got an error in the trac.log file:

2010-05-09 23:51:41,625 Trac[env] INFO: -------------------------------- environment startup [Trac 0.11.7] --------------------------------
2010-05-09 23:51:41,654 Trac[loader] DEBUG: Loading svnauthz.admin_ui from /usr/lib/python2.5/site-packages/SvnAuthzAdminPlugin-0.1.2._Moved.to.Trac.0.11_-py2.5.egg
2010-05-09 23:51:41,657 Trac[loader] ERROR: Skipping "svnauthz.admin_ui = svnauthz.admin_ui": (can't import "ImportError: cannot import name get_module_path")

I'm using Trac 0.11.7 from Debian unstable.

Attachments (0)

Change History (6)

comment:1 Changed 4 years ago by alexander.papaspyrou@…

Confirmed for Ubuntu Lucid (10.04 LTS) with 0.11.7 as well.

comment:2 Changed 4 years ago by rjollos

  • Resolution set to worksforme
  • Status changed from new to closed

I think you need to install setuptools.

comment:3 Changed 4 years ago by rjollos

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Actually, looks like that is not the problem. Please try removing get_pkginfo, get_module_path from the 5th line of admin_ui.

comment:4 Changed 4 years ago by saw

Confirmed for Debian Lenny with 0.11.7.
Removing import get_pkginfo, get_module_path from admin_ui works for me.

comment:5 Changed 4 years ago by rjollos

Thanks for the feedback!

comment:6 Changed 4 years ago by rjollos

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [8887]) Removed incorrect package imports. Fixes #7096.

Add Comment

Modify Ticket

Action
as closed .
as The resolution will be set. Next status will be 'closed'.
to The owner will be changed from kisg. Next status will be 'closed'.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.